# CVE-2026-63493: Snipe-IT: 2FA bypass via the API token flow

> Attackers with valid passwords bypass two-factor authentication via API tokens to read/modify data or take over admin accounts in Snipe-IT.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-hxcx-9h4f-42xx

## What is CVE-2026-63493?

CVE-2026-63493 is a high-severity authentication bypass vulnerability in Snipeitapp Snipe-It, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Snipe-IT is an IT asset/license management system. Prior to 8.7.0, a password-authenticated session for an account with self.api permission can reach the personal-access-token API flow before completing the account's second-factor challenge because CheckForTwoFactor is enforced in the web middleware group but not the API middleware group. The advisory states that the resulting persistent API token can read and modify resources with the victim's permissions and, for an administrator, can reach the users/two_factor_reset endpoint. Resetting the administrator's enrolled second factor allows the password-holding attacker to enroll an attacker-controlled factor, take over the administrator's web account, and lock out the legitimate user. The token does not create a web session, but it provides broad API access while the same browser session remains blocked at the two-factor page. This vulnerability is fixed in 8.7.0.

Weakness: CWE-288 (Authentication Bypass Using an Alternate Path or Channel)

## Which versions are affected by CVE-2026-63493?

2 open source packages ship an affected version, including snipe/snipe-it. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `snipe/snipe-it` | Packagist | All versions | 8.7.0 |
| `snipe/snipe-it` | Packagist | All versions | 8.7.0 |

Products: Snipeitapp Snipe-It.

## How do I fix CVE-2026-63493?

Upgrade snipe/snipe-it to 8.7.0 or later.

## Is CVE-2026-63493 being exploited?

There is no known exploitation of CVE-2026-63493 in the wild and no public exploit code.

## Other vulnerabilities in Snipeitapp Snipe-It

- [CVE-2025-63601](https://insights.sbomify.com/CVE-2025-63601/): File upload in n/a (critical 9.9)
- [CVE-2026-37709](https://insights.sbomify.com/CVE-2026-37709/): Snipe-IT has insecure permissions in file uploads (critical 9.8)
- [CVE-2026-86738](https://insights.sbomify.com/CVE-2026-86738/): Snipe-IT before 8.7.0 CSS Injection via Custom CSS (critical 9.3)
- [CVE-2026-116199](https://insights.sbomify.com/CVE-2026-116199/): Snipe-IT before 8.6.3 Authentication Bypass via Google SSO Callback (critical 9.2)
- [CVE-2022-1380](https://insights.sbomify.com/CVE-2022-1380/): Stored Cross Site Scripting vulnerability in Item name parameter in snipe/snipe-it (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63493 and fix it if it is affected.

What it is: CVE-2026-63493 is a high-severity authentication bypass vulnerability in Snipeitapp Snipe-It, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-63493 in the wild and no public exploit code.

Affected packages and fixed versions:
- snipe/snipe-it (Packagist): affected all versions; fixed in 8.7.0
- snipe/snipe-it (Packagist): affected all versions; fixed in 8.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63493/ (Markdown: https://insights.sbomify.com/CVE-2026-63493/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63493
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63493
- OSV: https://osv.dev/vulnerability/CVE-2026-63493

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63493/
Summaries are generated and may contain mistakes; the official description above is the record.
