# CVE-2026-63498: Snipe-IT: Stored XSS via Inline XML Rendering in the Uploaded Files API

> Authenticated attackers can execute JavaScript in victims' browsers via malicious XML attachments, leading to session hijacking or data theft.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** GHSA-396x-xmvh-p563

## What is CVE-2026-63498?

CVE-2026-63498 is a high-severity cross-site scripting vulnerability in Snipeitapp Snipe-It, published on 24 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Snipe-IT is an IT asset/license management system. Prior to 8.7.0, the uploaded-files API endpoint GET /api/v1/{object_type}/{id}/files/{file_id} allows an authenticated user with file-management access to upload XML and XSLT attachments and request them with the inline=true parameter. The app/Http/Controllers/Api/UploadedFilesController.php show() path does not apply the safe-inline allowlist used by the equivalent web controller, so the browser can process an attacker-controlled xml-stylesheet reference and execute JavaScript generated by the stylesheet in the Snipe-IT origin. A victim who is authorized to view the object must open the attachment URL, after which the script can read same-origin data and perform authenticated actions with the victim's privileges. This issue is fixed in version 8.7.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-63498?

2 open source packages ship an affected version, including snipe/snipe-it. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `snipe/snipe-it` | Packagist | All versions | 8.7.0 |
| `snipe/snipe-it` | Packagist | All versions | 8.7.0 |

Products: Snipeitapp Snipe-It.

## How do I fix CVE-2026-63498?

Upgrade snipe/snipe-it to 8.7.0 or later.

## Is CVE-2026-63498 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63498 exists.

## Other vulnerabilities in Snipeitapp Snipe-It

- [CVE-2025-63601](https://insights.sbomify.com/CVE-2025-63601/): File upload in n/a (critical 9.9)
- [CVE-2026-37709](https://insights.sbomify.com/CVE-2026-37709/): Snipe-IT has insecure permissions in file uploads (critical 9.8)
- [CVE-2026-86738](https://insights.sbomify.com/CVE-2026-86738/): Snipe-IT before 8.7.0 CSS Injection via Custom CSS (critical 9.3)
- [CVE-2026-116199](https://insights.sbomify.com/CVE-2026-116199/): Snipe-IT before 8.6.3 Authentication Bypass via Google SSO Callback (critical 9.2)
- [CVE-2022-1380](https://insights.sbomify.com/CVE-2022-1380/): Stored Cross Site Scripting vulnerability in Item name parameter in snipe/snipe-it (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63498 and fix it if it is affected.

What it is: CVE-2026-63498 is a high-severity cross-site scripting vulnerability in Snipeitapp Snipe-It, published on 24 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63498 exists.

Affected packages and fixed versions:
- snipe/snipe-it (Packagist): affected all versions; fixed in 8.7.0
- snipe/snipe-it (Packagist): affected all versions; fixed in 8.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63498/ (Markdown: https://insights.sbomify.com/CVE-2026-63498/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63498
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63498
- OSV: https://osv.dev/vulnerability/CVE-2026-63498

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63498/
Summaries are generated and may contain mistakes; the official description above is the record.
