CVE-2026-6352 Incorrect Authorization in GitLab

Low 2.7 Published Updated

Authenticated users with auditor-level access can improperly modify compliance violation records due to missing authorization checks in GraphQL operations.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-6352?

CVE-2026-6352 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 8 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 18.2 before 18.11.7, 19.0 before 19.0.4, and 19.1 before 19.1.2 that under certain conditions could have allowed an authenticated user with auditor-level access to modify compliance violation records due to improper authorization on certain GraphQL operations.

Weakness: CWE-863

Which versions are affected by CVE-2026-6352?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 18.2.018.11.7, 19.0.4, 19.1.2

Products include Gitlab Gitlab.

How do I fix CVE-2026-6352?

Upgrade gitlab to a fixed version for your release line: 18.11.7, 19.0.4 or 19.1.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-6352 being exploited?

There is no known exploitation of CVE-2026-6352 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-6352, GHSA-7j3x-j5f8-qr4f, MINI-wp3j-7rjr-f59x, UBUNTU-CVE-2026-6352.

Is CVE-2026-6352 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free