# CVE-2026-63621: Apache Camel-Knative: CloudEvent extension fields received in structured content mode were mapped onto message headers without applying any header filter strategy

> Attackers can inject internal headers via CloudEvent JSON to trigger SSRF, path traversal, or redirection in Apache Camel routes.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-vvwm-3j43-7pfm

## What is CVE-2026-63621?

CVE-2026-63621 is a medium-severity server-side request forgery vulnerability in Apache Camel, published on 24 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation, Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') vulnerability in Apache Camel Knative component

The Knative consumer in camel-knative maps inbound CloudEvent attributes onto Camel message headers. In binary content mode the HTTP-header path filters Camel-internal headers through KnativeHttpHeaderFilterStrategy, but in structured content mode (Content-Type application/cloudevents+json) the CloudEvent extension fields are read directly from the JSON body and every extension key is copied into the Exchange headers without applying any HeaderFilterStrategy (CloudEventProcessors, spec versions 1.0, 1.0.1 and 1.0.2). As a result, an unauthenticated attacker can inject Camel-internal headers (e.g. CamelHttpUri, CamelHttpPath, CamelFileName) via a structured-mode CloudEvent request, matched case-insensitively against Camel's header map. When a route forwards messages from a Knative consumer to a header-driven component such as camel-http or camel-file, the injected headers override configured values, enabling server-side request forgery (SSRF), path traversal or message-dispatch redirection depending on the route. This is an incomplete fix of the inbound header filtering previously added for the binary content-mode path, and is the same pattern addressed in camel-cxf/camel-knative (CVE-2026-47323), camel-undertow (CVE-2025-30177), the broader incoming-header filter (CVE-2025-27636 and CVE-2025-29891), and the non-HTTP strategies (CVE-2026-40453).

This issue affects Apache Camel: from 3.15.0 before 4.14.9, from 4.15.0 before 4.18.4, from 4.19.0 before 4.21.0.

Users are recommended to upgrade to version 4.22.0, which fixes the issue. If users are on the 4.18.x LTS releases stream, then they are suggested to upgrade to 4.18.4. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.9. The non-LTS releases 4.15.0 through 4.17.0 and 4.19.0 through 4.21.0 are affected but do not receive a maintenance fix; users on those versions should upgrade to 4.18.4 or 4.22.0.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-63621?

6 open source packages ship an affected version, including org.apache.camel:camel-knative. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-knative` | Maven | From 3.15.0 | 4.14.9 |
| `org.apache.camel:camel-knative` | Maven | From 3.15.0 | 4.14.9 |
| `org.apache.camel:camel-knative` | Maven | From 4.15.0 | 4.18.4 |
| `org.apache.camel:camel-knative` | Maven | From 4.15.0 | 4.18.4 |
| `org.apache.camel:camel-knative` | Maven | From 4.19.0 | 4.22.0 |
| `org.apache.camel:camel-knative` | Maven | From 4.19.0 | 4.22.0 |

Products: Apache Camel.

## How do I fix CVE-2026-63621?

Upgrade org.apache.camel:camel-knative to a fixed version for your release line: 4.14.9, 4.18.4 or 4.22.0.

## Is CVE-2026-63621 being exploited?

There is no known exploitation of CVE-2026-63621 in the wild and no public exploit code.

Public exploit code:

- Reproducer for CVE-2026-63621 (Apache Camel camel-knative structured CloudEvent header injection) — Camel Spring Boot + Camel Quarkus (github_poc): https://github.com/oscerd/CVE-2026-63621

## Other vulnerabilities in Apache Camel

- [CVE-2026-33453](https://insights.sbomify.com/CVE-2026-33453/): Apache camel-coap allows header injection that can lead to remote code execution (critical 10.0)
- [CVE-2026-40453](https://insights.sbomify.com/CVE-2026-40453/): Apache Camel has an incomplete fix for CVE-2025-27636 (critical 9.9)
- [CVE-2026-80351](https://insights.sbomify.com/CVE-2026-80351/): Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod (critical 9.8)
- [CVE-2026-80352](https://insights.sbomify.com/CVE-2026-80352/): Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects (critical 9.8)
- [CVE-2026-71300](https://insights.sbomify.com/CVE-2026-71300/): Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63621 and fix it if it is affected.

What it is: CVE-2026-63621 is a medium-severity server-side request forgery vulnerability in Apache Camel, published on 24 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-63621 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.camel:camel-knative (Maven): affected from 3.15.0; fixed in 4.14.9
- org.apache.camel:camel-knative (Maven): affected from 3.15.0; fixed in 4.14.9
- org.apache.camel:camel-knative (Maven): affected from 4.15.0; fixed in 4.18.4
- org.apache.camel:camel-knative (Maven): affected from 4.15.0; fixed in 4.18.4
- org.apache.camel:camel-knative (Maven): affected from 4.19.0; fixed in 4.22.0
- org.apache.camel:camel-knative (Maven): affected from 4.19.0; fixed in 4.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63621/ (Markdown: https://insights.sbomify.com/CVE-2026-63621/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63621
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63621
- OSV: https://osv.dev/vulnerability/CVE-2026-63621

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63621/
Summaries are generated and may contain mistakes; the official description above is the record.
