{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-63626 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-63626 is a high-severity memory corruption vulnerability in cesanta mongoose, published on 14 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-63626 and fix it if it is affected.\n\nWhat it is: CVE-2026-63626 is a high-severity memory corruption vulnerability in cesanta mongoose, published on 14 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-63626 in the wild and no public exploit code.\n\nAffected product: cesanta mongoose. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-63626/ (Markdown: https://insights.sbomify.com/CVE-2026-63626/index.md)","id":"CVE-2026-63626","markdown":"https://insights.sbomify.com/CVE-2026-63626/index.md","name":"CVE-2026-63626","record":{"aliases":["DEBIAN-CVE-2026-63626","GHSA-pc66-j6r6-49x9","UBUNTU-CVE-2026-63626"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Embedded web server library","requires_auth":"none","summary":"An attacker on a PPP/PPPoE link can trigger out-of-bounds reads and heap overflows in Mongoose, potentially leading to code execution or denial of service.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"},{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"Mongoose is an embedded web server and network library. Prior to 7.23, ppp_handle_ipv6cp() in src/l2_ppp.c trusts the 16-bit IPv6CP len field without checking it against the received payload size. On a PPP or PPPoE link using MG_ENABLE_TCPIP and MG_ENABLE_IPV6, an unauthenticated adjacent peer can complete the required LCP exchange and send a short Configure-Request with an oversized length, causing ppp_tx_frame() to read beyond recv_queue.buf and write beyond tx.buf. The same length misuse can also expose adjacent heap bytes in a reply or hang the event loop through find_opt(). This issue is fixed in version 7.23.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in mongoose","id":"CVE-2026-63626","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"mppx: Gas Draining with padding","id":"CVE-2026-63627"},"packages":[],"prev":{"headline":"Libvirt: information disclosure via world-readable storage volume images during clone/convert","id":"CVE-2026-63623"},"products":["mongoose"],"published":"2026-10-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-15","vendors":["cesanta"]},"summary":"An attacker on a PPP/PPPoE link can trigger out-of-bounds reads and heap overflows in Mongoose, potentially leading to code execution or denial of service.","url":"https://insights.sbomify.com/CVE-2026-63626/"}