# CVE-2026-63626: Memory corruption in mongoose

> An attacker on a PPP/PPPoE link can trigger out-of-bounds reads and heap overflows in Mongoose, potentially leading to code execution or denial of service.

- **Severity:** High 8.8 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2026
- **Updated:** 15 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-63626, GHSA-pc66-j6r6-49x9, UBUNTU-CVE-2026-63626

## What is CVE-2026-63626?

CVE-2026-63626 is a high-severity memory corruption vulnerability in cesanta mongoose, published on 14 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Mongoose is an embedded web server and network library. Prior to 7.23, ppp_handle_ipv6cp() in src/l2_ppp.c trusts the 16-bit IPv6CP len field without checking it against the received payload size. On a PPP or PPPoE link using MG_ENABLE_TCPIP and MG_ENABLE_IPV6, an unauthenticated adjacent peer can complete the required LCP exchange and send a short Configure-Request with an oversized length, causing ppp_tx_frame() to read beyond recv_queue.buf and write beyond tx.buf. The same length misuse can also expose adjacent heap bytes in a reply or hang the event loop through find_opt(). This issue is fixed in version 7.23.

Weakness: CWE-125 (Out-of-bounds Read), CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2026-63626?


## How do I fix CVE-2026-63626?

Upgrade to a fixed version.

## Is CVE-2026-63626 being exploited?

There is no known exploitation of CVE-2026-63626 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63626 and fix it if it is affected.

What it is: CVE-2026-63626 is a high-severity memory corruption vulnerability in cesanta mongoose, published on 14 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-63626 in the wild and no public exploit code.

Affected product: cesanta mongoose. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63626/ (Markdown: https://insights.sbomify.com/CVE-2026-63626/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63626
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63626
- OSV: https://osv.dev/vulnerability/CVE-2026-63626

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63626/
Summaries are generated and may contain mistakes; the official description above is the record.
