{"answers":{"affected":"2 open source packages ship an affected version, including mppx.","exploited":"There is no known exploitation of CVE-2026-63627 in the wild and no public exploit code.","fix":"Upgrade mppx to 0.8.2 or later.","what":"CVE-2026-63627 is a medium-severity vulnerability in wevm mppx, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-63627 and fix it if it is affected.\n\nWhat it is: CVE-2026-63627 is a medium-severity vulnerability in wevm mppx, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-63627 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mppx (npm): affected all versions; fixed in 0.8.2\n- mppx (npm): affected all versions; fixed in 0.8.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-63627/ (Markdown: https://insights.sbomify.com/CVE-2026-63627/index.md)","id":"CVE-2026-63627","markdown":"https://insights.sbomify.com/CVE-2026-63627/index.md","name":"CVE-2026-63627","record":{"aliases":["GHSA-727h-3vm5-qwq6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","other"],"network_reachable":"yes","non_default_config":false,"product_category":"TypeScript payment library","requires_auth":"none","summary":"Attackers can inflate transaction fees paid by the server wallet by appending padding to calldata, causing financial loss and resource exhaustion.","user_interaction":"not_required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"mppx is a TypeScript interface for machine payments protocol. Prior to 0.8.2, FeePayerPolicy in src/tempo/internal/fee-payer.ts used decodeFunctionData to validate fee-sponsored calldata but did not reject trailing bytes. A client could append nonzero padding that increased intrinsic calldata gas while gas_limit and max_fee_per_gas remained within policy caps, causing the server fee_payer wallet to pay substantially more than the decoded transaction required. The tested 16 KB header limit bounded the demonstrated padding to about 5,500 bytes and produced approximately five times the normal transaction fee. This issue is fixed in version 0.8.2.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"mppx: Gas Draining with padding","id":"CVE-2026-63627","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"business_logic","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"mppx: Gas Draining with access list","id":"CVE-2026-63628"},"packages":[{"ecosystem":"npm","fixed":["0.8.2"],"introduced":["0"],"last_affected":[],"package":"mppx","purl":null,"source":"GHSA-727h-3vm5-qwq6"},{"ecosystem":"npm","fixed":["0.8.2"],"introduced":["0"],"last_affected":[],"package":"mppx","purl":"pkg:npm/mppx","source":"GHSA-727h-3vm5-qwq6"}],"prev":{"headline":"Memory corruption in mongoose","id":"CVE-2026-63626"},"products":["mppx"],"published":"2026-09-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-23","vendors":["wevm"]},"summary":"Attackers can inflate transaction fees paid by the server wallet by appending padding to calldata, causing financial loss and resource exhaustion.","url":"https://insights.sbomify.com/CVE-2026-63627/"}