# CVE-2026-63627: mppx: Gas Draining with padding

> Attackers can inflate transaction fees paid by the server wallet by appending padding to calldata, causing financial loss and resource exhaustion.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** GHSA-727h-3vm5-qwq6

## What is CVE-2026-63627?

CVE-2026-63627 is a medium-severity vulnerability in wevm mppx, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

mppx is a TypeScript interface for machine payments protocol. Prior to 0.8.2, FeePayerPolicy in src/tempo/internal/fee-payer.ts used decodeFunctionData to validate fee-sponsored calldata but did not reject trailing bytes. A client could append nonzero padding that increased intrinsic calldata gas while gas_limit and max_fee_per_gas remained within policy caps, causing the server fee_payer wallet to pay substantially more than the decoded transaction required. The tested 16 KB header limit bounded the demonstrated padding to about 5,500 bytes and produced approximately five times the normal transaction fee. This issue is fixed in version 0.8.2.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-63627?

2 open source packages ship an affected version, including mppx.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mppx` | npm | All versions | 0.8.2 |
| `mppx` | npm | All versions | 0.8.2 |

## How do I fix CVE-2026-63627?

Upgrade mppx to 0.8.2 or later.

## Is CVE-2026-63627 being exploited?

There is no known exploitation of CVE-2026-63627 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63627 and fix it if it is affected.

What it is: CVE-2026-63627 is a medium-severity vulnerability in wevm mppx, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-63627 in the wild and no public exploit code.

Affected packages and fixed versions:
- mppx (npm): affected all versions; fixed in 0.8.2
- mppx (npm): affected all versions; fixed in 0.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63627/ (Markdown: https://insights.sbomify.com/CVE-2026-63627/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63627
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63627
- OSV: https://osv.dev/vulnerability/CVE-2026-63627

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63627/
Summaries are generated and may contain mistakes; the official description above is the record.
