# CVE-2026-63628: mppx: Gas Draining with access list

> Attackers can inflate transaction fees for the fee-payer wallet by injecting fabricated access-list entries, causing financial denial of service.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** GHSA-vc9j-9wph-qghj

## What is CVE-2026-63628?

CVE-2026-63628 is a medium-severity denial of service vulnerability in wevm mppx, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

mppx is a TypeScript interface for machine payments protocol. Prior to 0.8.2, the fee-payer cosigning path in src/tempo/internal/fee-payer.ts copied a client-supplied access_list from a 0x78 FeePayerEnvelope without validating its length or contents. Because EIP-2930 access-list entries consume intrinsic gas even when the listed addresses are never used, a client could add fabricated address-only entries and cause the server fee_payer wallet to pay unnecessary transaction fees. The demonstrated 180-entry list remained within the 500,000 gas policy cap, 16 KB header limit, and RPC simulation budget while increasing the fee by approximately 9.4 times. This issue is fixed in version 0.8.2.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-63628?

2 open source packages ship an affected version, including mppx.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mppx` | npm | All versions | 0.8.2 |
| `mppx` | npm | All versions | 0.8.2 |

## How do I fix CVE-2026-63628?

Upgrade mppx to 0.8.2 or later.

## Is CVE-2026-63628 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63628 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63628 and fix it if it is affected.

What it is: CVE-2026-63628 is a medium-severity denial of service vulnerability in wevm mppx, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63628 exists.

Affected packages and fixed versions:
- mppx (npm): affected all versions; fixed in 0.8.2
- mppx (npm): affected all versions; fixed in 0.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63628/ (Markdown: https://insights.sbomify.com/CVE-2026-63628/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63628
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63628
- OSV: https://osv.dev/vulnerability/CVE-2026-63628

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63628/
Summaries are generated and may contain mistakes; the official description above is the record.
