{"answers":{"affected":"3 open source packages ship an affected version, including onnx.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63632 exists.","fix":"Upgrade onnx to 1.22.0 or later.","what":"CVE-2026-63632 is a low-severity memory corruption vulnerability in onnx, published on 18 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-63632 and fix it if it is affected.\n\nWhat it is: CVE-2026-63632 is a low-severity memory corruption vulnerability in onnx, published on 18 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63632 exists.\n\nAffected packages and fixed versions:\n- onnx (PyPI): affected from 1.3.0; fixed in 1.22.0\n- onnx (PyPI): affected from 1.3.0; fixed in 1.22.0\n- onnx (PyPI): affected from 1.3.0; fixed in 1.22.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-63632/ (Markdown: https://insights.sbomify.com/CVE-2026-63632/index.md)","id":"CVE-2026-63632","markdown":"https://insights.sbomify.com/CVE-2026-63632/index.md","name":"CVE-2026-63632","record":{"aliases":["AZL-96728","DEBIAN-CVE-2026-63632","ECHO-2342-84be-f23c","GHSA-p893-rvq9-2xf9","PYSEC-2026-3587","UBUNTU-CVE-2026-63632"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"ONNX machine learning library","requires_auth":"none","summary":"An attacker can cause a denial of service via heap buffer overflow in ONNX version converter when processing malformed Gemm nodes with undersized input shapes.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":3.3,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"Open Neural Network Exchange (ONNX) is an open standard for machine learning interoperability. From 1.3.0 until 1.22.0, onnx.version_converter.convert_version() can perform an out-of-bounds read in Gemm_7_6::adapt_gemm_7_6() in onnx/version_converter/adapters/gemm_7_6.h when a Gemm node has input tensors with fewer than two dimensions because B_shape[1], A_shape[0], or A_shape[1] is accessed without a rank check, potentially causing a process crash during an opset 7 to 6 downgrade. This issue is fixed in version 1.22.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"ONNX: Heap-Buffer-Overflow READ in Gemm Version Converter Adapter via Undersized Input Shape","id":"CVE-2026-63632","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"FreeRDP: Heap buffer overflow in Opus audio decode (`freerdp_dsp_decode_opus` resizes the wrong stream) — server→client","id":"CVE-2026-63633"},"packages":[{"ecosystem":"PyPI","fixed":["1.22.0"],"introduced":["1.3.0"],"last_affected":[],"package":"onnx","purl":null,"source":"GHSA-p893-rvq9-2xf9"},{"ecosystem":"PyPI","fixed":["1.22.0"],"introduced":["1.3.0"],"last_affected":[],"package":"onnx","purl":"pkg:pypi/onnx","source":"GHSA-p893-rvq9-2xf9"},{"ecosystem":"PyPI","fixed":["1.22.0"],"introduced":["1.3.0"],"last_affected":[],"package":"onnx","purl":"pkg:pypi/onnx","source":"PYSEC-2026-3587"}],"prev":{"headline":"BentoPDF: Workflow Import Allows Unvalidated TSA URL Leading to PDF Hash Exfiltration via RFC 3161 Requests","id":"CVE-2026-63630"},"products":["onnx"],"published":"2026-08-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-18","vendors":["onnx"]},"summary":"An attacker can cause a denial of service via heap buffer overflow in ONNX version converter when processing malformed Gemm nodes with undersized input shapes.","url":"https://insights.sbomify.com/CVE-2026-63632/"}