# CVE-2026-63632: ONNX: Heap-Buffer-Overflow READ in Gemm Version Converter Adapter via Undersized Input Shape

> An attacker can cause a denial of service via heap buffer overflow in ONNX version converter when processing malformed Gemm nodes with undersized input shapes.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** AZL-96728, DEBIAN-CVE-2026-63632, ECHO-2342-84be-f23c, GHSA-p893-rvq9-2xf9, PYSEC-2026-3587, UBUNTU-CVE-2026-63632

## What is CVE-2026-63632?

CVE-2026-63632 is a low-severity memory corruption vulnerability in onnx, published on 18 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Open Neural Network Exchange (ONNX) is an open standard for machine learning interoperability. From 1.3.0 until 1.22.0, onnx.version_converter.convert_version() can perform an out-of-bounds read in Gemm_7_6::adapt_gemm_7_6() in onnx/version_converter/adapters/gemm_7_6.h when a Gemm node has input tensors with fewer than two dimensions because B_shape[1], A_shape[0], or A_shape[1] is accessed without a rank check, potentially causing a process crash during an opset 7 to 6 downgrade. This issue is fixed in version 1.22.0.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-63632?

3 open source packages ship an affected version, including onnx.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `onnx` | PyPI | From 1.3.0 | 1.22.0 |
| `onnx` | PyPI | From 1.3.0 | 1.22.0 |
| `onnx` | PyPI | From 1.3.0 | 1.22.0 |

## How do I fix CVE-2026-63632?

Upgrade onnx to 1.22.0 or later.

## Is CVE-2026-63632 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63632 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63632 and fix it if it is affected.

What it is: CVE-2026-63632 is a low-severity memory corruption vulnerability in onnx, published on 18 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63632 exists.

Affected packages and fixed versions:
- onnx (PyPI): affected from 1.3.0; fixed in 1.22.0
- onnx (PyPI): affected from 1.3.0; fixed in 1.22.0
- onnx (PyPI): affected from 1.3.0; fixed in 1.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63632/ (Markdown: https://insights.sbomify.com/CVE-2026-63632/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63632
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63632
- OSV: https://osv.dev/vulnerability/CVE-2026-63632

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63632/
Summaries are generated and may contain mistakes; the official description above is the record.
