# CVE-2026-63645: OpenObserve: Unauthenticated /config/runtime endpoint exposes PostgreSQL database credentials

> Unauthenticated access to the /config/runtime endpoint exposes PostgreSQL credentials and internal deployment details in OpenObserve.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 24 Sep 2026
- **Updated:** 5 Oct 2026
- **Also known as:** GHSA-v496-g5c9-vqxw

## What is CVE-2026-63645?

CVE-2026-63645 is a high-severity vulnerability in openobserve, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenObserve is a cloud-native observability platform. Prior to 0.90.3, OpenObserve registers the /config/runtime endpoint without authentication and serializes the complete server configuration after applying the hide_sensitive_fields keyword filter. The filter does not recognize dsn or creds field names, so meta_postgres_dsn, meta_postgres_ro_dsn, meta_ddl_dsn, and usage_reporting_creds can be returned in plaintext to an unauthenticated network client. PostgreSQL deployments can expose database credentials, and the same response can disclose the root administrator email address, internal NATS address, filesystem layout, and other deployment details. This issue is fixed in version 0.90.3.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-63645?


## How do I fix CVE-2026-63645?

No fix has been published for CVE-2026-63645 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-63645 being exploited?

There is no known exploitation of CVE-2026-63645 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63645 and fix it if it is affected.

What it is: CVE-2026-63645 is a high-severity vulnerability in openobserve, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-63645 in the wild and no public exploit code.

Affected product: openobserve. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63645/ (Markdown: https://insights.sbomify.com/CVE-2026-63645/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63645
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63645
- OSV: https://osv.dev/vulnerability/CVE-2026-63645

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63645/
Summaries are generated and may contain mistakes; the official description above is the record.
