CVE-2026-6365 Drupal core - Critical - Cross-site scripting - SA-CORE-2026-001
Drupal core contains a cross-site scripting vulnerability allowing attackers to inject malicious scripts, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-6365?
CVE-2026-6365 is a medium-severity cross-site scripting vulnerability in Drupal Drupal, published on 19 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS).
This issue affects Drupal core: from 8.0.0 before 10.5.9, from 10.6.0 before 10.6.7, from 11.0.0 before 11.2.11, from 11.3.0 before 11.3.7.
Weakness: CWE-79
Which versions are affected by CVE-2026-6365?
10 open source packages ship an affected version, including drupal/core and drupal. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 10.6.0 | 10.6.7 |
drupal/core Packagist | From 10.6.0 | 10.6.7 |
drupal/core Packagist | From 11.0.0 | 11.2.11 |
drupal/core Packagist | From 11.0.0 | 11.2.11 |
drupal/core Packagist | From 11.3.0 | 11.3.7 |
drupal/core Packagist | From 11.3.0 | 11.3.7 |
4 more packages
drupal/core Packagist | From 8.0.0 | 10.5.9, 10.6.7, 11.2.11, 11.3.7 |
drupal/core Packagist | From 8.0.0 | 10.5.9 |
drupal/core Packagist | From 8.0.0 | 10.5.9 |
drupal Bitnami | From 8.0.0 | 10.5.9, 10.6.7, 11.2.11, 11.3.7 |
Products include Drupal Drupal.
How do I fix CVE-2026-6365?
Upgrade drupal/core to a fixed version for your release line: 10.6.7, 11.2.11, 11.3.7 or 10.5.9.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-6365 being exploited?
There is no known exploitation of CVE-2026-6365 in the wild and no public exploit code.
Other vulnerabilities in Drupal Drupal
Sources
Also known as BIT-drupal-2026-6365, CLSA-2026-1778201069, DRUPAL-CORE-2026-001, GHSA-f3cj-mjqm-fhvj.