# CVE-2026-6366: Drupal core - Moderately critical - Gadget Chain - SA-CORE-2026-002

> Drupal core allows object injection via gadget chains, potentially enabling remote code execution for attackers.

- **Severity:** Medium 6.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 May 2026
- **Updated:** 21 May 2026
- **Also known as:** BIT-drupal-2026-6366, DRUPAL-CORE-2026-002, GHSA-xmjc-63pr-2mpg

## What is CVE-2026-6366?

CVE-2026-6366 is a medium-severity unsafe deserialization vulnerability in Drupal Drupal, published on 19 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Improperly Controlled Modification of Dynamically-Determined Object Attributes vulnerability in Drupal Drupal core allows Object Injection.

This issue affects Drupal core: from 8.0.0 before 10.5.9, from 10.6.0 before 10.6.7, from 11.0.0 before 11.2.11, from 11.3.0 before 11.3.7.

Weakness: CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes)

## Which versions are affected by CVE-2026-6366?

10 open source packages ship an affected version, including drupal/core and drupal. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 10.6.0 | 10.6.7 |
| `drupal/core` | Packagist | From 10.6.0 | 10.6.7 |
| `drupal/core` | Packagist | From 11.0.0 | 11.2.11 |
| `drupal/core` | Packagist | From 11.0.0 | 11.2.11 |
| `drupal/core` | Packagist | From 11.3.0 | 11.3.7 |
| `drupal/core` | Packagist | From 11.3.0 | 11.3.7 |
| `drupal/core` | Packagist | From 8.0.0 | 10.5.9, 10.6.7, 11.2.11, 11.3.7 |
| `drupal/core` | Packagist | From 8.0.0 | 10.5.9 |
| `drupal/core` | Packagist | From 8.0.0 | 10.5.9 |
| `drupal` | Bitnami | From 8.0.0 | 10.5.9, 10.6.7, 11.2.11, 11.3.7 |

Products: Drupal Drupal.

## How do I fix CVE-2026-6366?

Upgrade drupal/core to a fixed version for your release line: 10.6.7, 11.2.11, 11.3.7 or 10.5.9.

## Is CVE-2026-6366 being exploited?

There is no known exploitation of CVE-2026-6366 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Drupal

- [CVE-2026-9082](https://insights.sbomify.com/CVE-2026-9082/): Drupal Core SQL Injection (critical 9.8, exploited in the wild)
- [CVE-2020-13671](https://insights.sbomify.com/CVE-2020-13671/): Drupal core Un-restricted Upload of File (high 8.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6366 and fix it if it is affected.

What it is: CVE-2026-6366 is a medium-severity unsafe deserialization vulnerability in Drupal Drupal, published on 19 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6366 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 10.6.0; fixed in 10.6.7
- drupal/core (Packagist): affected from 10.6.0; fixed in 10.6.7
- drupal/core (Packagist): affected from 11.0.0; fixed in 11.2.11
- drupal/core (Packagist): affected from 11.0.0; fixed in 11.2.11
- drupal/core (Packagist): affected from 11.3.0; fixed in 11.3.7
- drupal/core (Packagist): affected from 11.3.0; fixed in 11.3.7
- drupal/core (Packagist): affected from 8.0.0; fixed in 10.5.9, 10.6.7, 11.2.11, 11.3.7
- drupal/core (Packagist): affected from 8.0.0; fixed in 10.5.9
- drupal/core (Packagist): affected from 8.0.0; fixed in 10.5.9
- drupal (Bitnami): affected from 8.0.0; fixed in 10.5.9, 10.6.7, 11.2.11, 11.3.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6366/ (Markdown: https://insights.sbomify.com/CVE-2026-6366/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6366
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6366
- OSV: https://osv.dev/vulnerability/CVE-2026-6366

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6366/
Summaries are generated and may contain mistakes; the official description above is the record.
