# CVE-2026-63667: ApostropheCMS: Arbitrary file read via import-export attachment-name path traversal

> An authenticated contributor can exploit path traversal in the import-export module to read arbitrary host files and publish them publicly.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Aug 2026
- **Updated:** 17 Aug 2026
- **Also known as:** GHSA-79qf-vqgc-7xx3

## What is CVE-2026-63667?

CVE-2026-63667 is a medium-severity path traversal vulnerability in apostrophecms apostrophe, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ApostropheCMS is an open-source Node.js content management system. Prior to 3.6.2, the import-export module in packages/import-export/lib/formats/gzip.js constructs an attachment source path from the attacker-controlled _id, name, and extension fields in aposAttachments.json without ensuring that the resolved path remains under the extracted attachments directory, allowing an authenticated contributor to import a crafted archive, read a host file with an allowed extension, and publish the copied file at an unauthenticated uploads URL. This issue is fixed in version 3.6.2.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-63667?

2 open source packages ship an affected version, including @apostrophecms/import-export.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@apostrophecms/import-export` | npm | All versions | 3.6.2 |
| `@apostrophecms/import-export` | npm | All versions | 3.6.2 |

## How do I fix CVE-2026-63667?

Upgrade @apostrophecms/import-export to 3.6.2 or later.

## Is CVE-2026-63667 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63667 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63667 and fix it if it is affected.

What it is: CVE-2026-63667 is a medium-severity path traversal vulnerability in apostrophecms apostrophe, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63667 exists.

Affected packages and fixed versions:
- @apostrophecms/import-export (npm): affected all versions; fixed in 3.6.2
- @apostrophecms/import-export (npm): affected all versions; fixed in 3.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63667/ (Markdown: https://insights.sbomify.com/CVE-2026-63667/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63667
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63667
- OSV: https://osv.dev/vulnerability/CVE-2026-63667

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63667/
Summaries are generated and may contain mistakes; the official description above is the record.
