# CVE-2026-63669: ApostropheCMS: Missing destination-parent authorization in page `move()` allows a low-privileged editor to move and re-rank pages inside a restricted subtree

> Low-privileged editors can move pages into restricted areas and re-rank protected siblings due to missing authorization checks in the page move operation.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Aug 2026
- **Updated:** 17 Aug 2026
- **Also known as:** GHSA-wr5r-wqp2-x4fh

## What is CVE-2026-63669?

CVE-2026-63669 is a medium-severity missing authorization vulnerability in apostrophecms apostrophe, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ApostropheCMS is an open-source Node.js content management system. Prior to 4.32.0, the page module's move() operation fails to enforce the destination parent's _create permission because its oldParent archive condition disables the check for ordinary moves, allowing an authenticated editor or contributor to use _targetId and _position through the page REST update endpoint to move a controlled page into a restricted subtree and make nudgeNewPeers() updateMany re-rank protected sibling pages. This issue is fixed in version 4.32.0.

Weakness: CWE-862 (Missing Authorization), CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-63669?

2 open source packages ship an affected version, including apostrophe.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apostrophe` | npm | All versions | 4.32.0 |
| `apostrophe` | npm | All versions | 4.32.0 |

## How do I fix CVE-2026-63669?

Upgrade apostrophe to 4.32.0 or later.

## Is CVE-2026-63669 being exploited?

There is no known exploitation of CVE-2026-63669 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63669 and fix it if it is affected.

What it is: CVE-2026-63669 is a medium-severity missing authorization vulnerability in apostrophecms apostrophe, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-63669 in the wild and no public exploit code.

Affected packages and fixed versions:
- apostrophe (npm): affected all versions; fixed in 4.32.0
- apostrophe (npm): affected all versions; fixed in 4.32.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63669/ (Markdown: https://insights.sbomify.com/CVE-2026-63669/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63669
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63669
- OSV: https://osv.dev/vulnerability/CVE-2026-63669

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63669/
Summaries are generated and may contain mistakes; the official description above is the record.
