CVE-2026-63686 Apache HTTP Server: mod_xml2enc crash on charset conversion failure

High 7.5 Published Updated

An untrusted backend server can cause a denial of service in Apache HTTP Server via a proxied response with a failing charset conversion.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-63686?

CVE-2026-63686 is a high-severity vulnerability in Apache Http Server, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A NULL pointer dereference in mod_xml2enc in Apache Software Foundation Apache HTTP Server before 2.4.69 on all platforms allows an untrusted backend server to cause a denial of service via a proxied response with a charset whose conversion partially succeeds then fails.

Users are recommended to upgrade to version 2.4.69, which fixes this issue.

Weakness: CWE-476

Which versions are affected by CVE-2026-63686?

1 open source package ship an affected version, including apache. It affects 1 product.

PackageAffectedFixed in
apache BitnamiFrom 2.4.02.4.69

Products include Apache Http Server.

How do I fix CVE-2026-63686?

Upgrade apache to 2.4.69 or later.

Is CVE-2026-63686 being exploited?

There is no known exploitation of CVE-2026-63686 in the wild and no public exploit code.

All Apache Http Server vulnerabilities

Sources

Also known as ALPINE-CVE-2026-63686, AZL-106755, BELL-CVE-2026-63686, BIT-apache-2026-63686, CLSA-2026-1791488147, CLSA-2026-1791552137 and 10 more.

Is CVE-2026-63686 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free