# CVE-2026-63718: Apache HTTP Server: mod_proxy_uwsgi Transfer-Encoding response smuggling

> Attackers can exploit response smuggling in mod_proxy_uwsgi to manipulate HTTP responses, potentially leading to cache poisoning or data exposure.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2026
- **Updated:** 1 Oct 2026
- **Also known as:** ALPINE-CVE-2026-63718, AZL-108080, BELL-CVE-2026-63718, BIT-apache-2026-63718, DEBIAN-CVE-2026-63718, ECHO-3b80-2eed-e08d, GHSA-9fgx-g8xr-w8vf, MINI-4mjp-4w39-3prq, ROOT-OS-DEBIAN-12-CVE-2026-63718, UBUNTU-CVE-2026-63718

## What is CVE-2026-63718?

CVE-2026-63718 is a high-severity vulnerability in Apache Http Server, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') response smuggling vulnerability in Apache HTTP Server via mod_proxy_uwsgi and a crafted uwsgi response with Transfer-Encoding.

This issue affects Apache HTTP Server: from 2.4.30 through 2.4.68.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2026-63718?

1 open source package ship an affected version, including apache. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.30 | 2.4.69 |

Products: Apache Http Server.

## How do I fix CVE-2026-63718?

Upgrade apache to 2.4.69 or later.

## Is CVE-2026-63718 being exploited?

There is no known exploitation of CVE-2026-63718 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63718 and fix it if it is affected.

What it is: CVE-2026-63718 is a high-severity vulnerability in Apache Http Server, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-63718 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.30; fixed in 2.4.69

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63718/ (Markdown: https://insights.sbomify.com/CVE-2026-63718/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63718
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63718
- OSV: https://osv.dev/vulnerability/CVE-2026-63718

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63718/
Summaries are generated and may contain mistakes; the official description above is the record.
