# CVE-2026-63732: 9router before 0.4.60 Remote Code Execution via default password

> Remote attackers can exploit hardcoded default credentials and header spoofing to register malicious plugins and execute arbitrary code on 9router servers.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 23 Jul 2026
- **Updated:** 27 Jul 2026
- **Also known as:** GHSA-qvg7-rqwf-6wmh

## What is CVE-2026-63732?

CVE-2026-63732 is a critical vulnerability in decolua 9router, published on 23 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

9router 0.4.59 (fixed in 0.4.60) contains a chain of vulnerabilities: a hardcoded default password (123456) that authenticates any fresh installation, a bypass of the LOCAL_ONLY network gate via a spoofed Host header, and unvalidated arguments passed to child_process.spawn() when registering MCP plugins. A remote, unauthenticated attacker can log in with the default credential, spoof the Host header to reach local-only routes, and register a malicious MCP plugin (e.g. node -e <payload>) to achieve arbitrary code execution on the host operating system when the plugin's SSE endpoint is triggered.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-63732?


## How do I fix CVE-2026-63732?

No fix has been published for CVE-2026-63732 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-63732 being exploited?

There is no known exploitation of CVE-2026-63732 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63732 and fix it if it is affected.

What it is: CVE-2026-63732 is a critical vulnerability in decolua 9router, published on 23 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-63732 in the wild and no public exploit code.

Affected product: decolua 9router. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63732/ (Markdown: https://insights.sbomify.com/CVE-2026-63732/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63732
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63732
- OSV: https://osv.dev/vulnerability/CVE-2026-63732

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63732/
Summaries are generated and may contain mistakes; the official description above is the record.
