# CVE-2026-63738: SurrealDB 3.1.0 before 3.1.5 Field Permission Bypass via Traversal

> Attackers with table-level access can bypass field-level permissions to read hidden data via graph traversals in SurrealDB.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2026
- **Updated:** 28 Jul 2026
- **Also known as:** GHSA-hv6h-hc26-q48p

## What is CVE-2026-63738?

CVE-2026-63738 is a medium-severity missing authorization vulnerability in Surrealdb Surrealdb, published on 20 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

SurrealDB versions 3.1.0 before 3.1.5 fail to enforce field-level SELECT permissions when records are accessed through graph-edge or back-reference traversals. Attackers with table-level SELECT access can read field values hidden by field-level permissions by materializing records through graph traversals instead of direct table scans.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-63738?

2 open source packages ship an affected version, including surrealdb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `surrealdb` | crates.io | From 3.1.0 | 3.1.5 |
| `surrealdb` | crates.io | From 3.1.0 | 3.1.5 |

Products: Surrealdb Surrealdb.

## How do I fix CVE-2026-63738?

Upgrade surrealdb to 3.1.5 or later.

## Is CVE-2026-63738 being exploited?

There is no known exploitation of CVE-2026-63738 in the wild and no public exploit code.

## Other vulnerabilities in Surrealdb Surrealdb

- [CVE-2025-71392](https://insights.sbomify.com/CVE-2025-71392/): SurrealDB before 2.2.2 SurrealQL Injection via export (critical 9.4)
- [CVE-2026-63756](https://insights.sbomify.com/CVE-2026-63756/): SurrealDB before 3.1.0 Privilege Escalation via RPC Session Race Condition (critical 9.2)
- [CVE-2026-63747](https://insights.sbomify.com/CVE-2026-63747/): SurrealDB before 3.1.0 Denial of Service via malformed RPC use (high 8.7)
- [CVE-2026-63757](https://insights.sbomify.com/CVE-2026-63757/): SurrealDB before 3.1.0 Session Hijacking via /rpc sessions (high 8.7)
- [CVE-2026-63760](https://insights.sbomify.com/CVE-2026-63760/): SurrealDB before 3.1.0 Denial of Service via JSON Parser (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63738 and fix it if it is affected.

What it is: CVE-2026-63738 is a medium-severity missing authorization vulnerability in Surrealdb Surrealdb, published on 20 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-63738 in the wild and no public exploit code.

Affected packages and fixed versions:
- surrealdb (crates.io): affected from 3.1.0; fixed in 3.1.5
- surrealdb (crates.io): affected from 3.1.0; fixed in 3.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63738/ (Markdown: https://insights.sbomify.com/CVE-2026-63738/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63738
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63738
- OSV: https://osv.dev/vulnerability/CVE-2026-63738

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63738/
Summaries are generated and may contain mistakes; the official description above is the record.
