CVE-2026-63763 SurrealDB before 2.5.0 Privilege Escalation via Future Fields
Unprivileged users can escalate privileges to root by planting malicious future fields that execute with higher-privileged user permissions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2026-63763?
CVE-2026-63763 is a high-severity vulnerability in Surrealdb Surrealdb, published on 20 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
SurrealDB before 2.5.0 and before 3.0.0-beta.3 contains a confused deputy privilege escalation vulnerability. Unprivileged users (e.g., those with the database editor role) can create or modify fields containing futures, functions, or closures. Because these are executed in the context of the invoking/querying user rather than their creator, an attacker can plant malicious logic that executes with a higher-privileged user's permissions when that user reads or writes the affected record. This can lead to full privilege escalation, including creation of a root owner and server takeover.
Weakness: CWE-639
Which versions are affected by CVE-2026-63763?
4 open source packages ship an affected version, including surrealdb. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
surrealdb crates.io | All versions | 2.5.0 |
surrealdb crates.io | All versions | 2.5.0 |
surrealdb crates.io | From 3.0.0-alpha.1 | 3.0.0-beta.3 |
surrealdb crates.io | From 3.0.0-alpha.1 | 3.0.0-beta.3 |
Products include Surrealdb Surrealdb.
How do I fix CVE-2026-63763?
Upgrade surrealdb to a fixed version for your release line: 2.5.0 or 3.0.0-beta.3.
Is CVE-2026-63763 being exploited?
There is no known exploitation of CVE-2026-63763 in the wild and no public exploit code.
Other vulnerabilities in Surrealdb Surrealdb
- CVE-2025-71392 SurrealDB before 2.2.2 SurrealQL Injection via export
- CVE-2026-63756 SurrealDB before 3.1.0 Privilege Escalation via RPC Session Race Condition
- CVE-2026-63747 SurrealDB before 3.1.0 Denial of Service via malformed RPC use
- CVE-2026-63757 SurrealDB before 3.1.0 Session Hijacking via /rpc sessions
- CVE-2026-63760 SurrealDB before 3.1.0 Denial of Service via JSON Parser
Sources
Also known as GHSA-3v2x-9xcv-2v2v, GHSA-5w8c-cvwv-f5px.