# CVE-2026-63763: SurrealDB before 2.5.0 Privilege Escalation via Future Fields

> Unprivileged users can escalate privileges to root by planting malicious future fields that execute with higher-privileged user permissions.

- **Severity:** High 7.5 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 20 Jul 2026
- **Updated:** 28 Jul 2026
- **Also known as:** GHSA-3v2x-9xcv-2v2v, GHSA-5w8c-cvwv-f5px

## What is CVE-2026-63763?

CVE-2026-63763 is a high-severity vulnerability in Surrealdb Surrealdb, published on 20 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

SurrealDB before 2.5.0 and before 3.0.0-beta.3 contains a confused deputy privilege escalation vulnerability. Unprivileged users (e.g., those with the database editor role) can create or modify fields containing futures, functions, or closures. Because these are executed in the context of the invoking/querying user rather than their creator, an attacker can plant malicious logic that executes with a higher-privileged user's permissions when that user reads or writes the affected record. This can lead to full privilege escalation, including creation of a root owner and server takeover.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-63763?

4 open source packages ship an affected version, including surrealdb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `surrealdb` | crates.io | All versions | 2.5.0 |
| `surrealdb` | crates.io | All versions | 2.5.0 |
| `surrealdb` | crates.io | From 3.0.0-alpha.1 | 3.0.0-beta.3 |
| `surrealdb` | crates.io | From 3.0.0-alpha.1 | 3.0.0-beta.3 |

Products: Surrealdb Surrealdb.

## How do I fix CVE-2026-63763?

Upgrade surrealdb to a fixed version for your release line: 2.5.0 or 3.0.0-beta.3.

## Is CVE-2026-63763 being exploited?

There is no known exploitation of CVE-2026-63763 in the wild and no public exploit code.

## Other vulnerabilities in Surrealdb Surrealdb

- [CVE-2025-71392](https://insights.sbomify.com/CVE-2025-71392/): SurrealDB before 2.2.2 SurrealQL Injection via export (critical 9.4)
- [CVE-2026-63756](https://insights.sbomify.com/CVE-2026-63756/): SurrealDB before 3.1.0 Privilege Escalation via RPC Session Race Condition (critical 9.2)
- [CVE-2026-63747](https://insights.sbomify.com/CVE-2026-63747/): SurrealDB before 3.1.0 Denial of Service via malformed RPC use (high 8.7)
- [CVE-2026-63757](https://insights.sbomify.com/CVE-2026-63757/): SurrealDB before 3.1.0 Session Hijacking via /rpc sessions (high 8.7)
- [CVE-2026-63760](https://insights.sbomify.com/CVE-2026-63760/): SurrealDB before 3.1.0 Denial of Service via JSON Parser (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63763 and fix it if it is affected.

What it is: CVE-2026-63763 is a high-severity vulnerability in Surrealdb Surrealdb, published on 20 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-63763 in the wild and no public exploit code.

Affected packages and fixed versions:
- surrealdb (crates.io): affected all versions; fixed in 2.5.0
- surrealdb (crates.io): affected all versions; fixed in 2.5.0
- surrealdb (crates.io): affected from 3.0.0-alpha.1; fixed in 3.0.0-beta.3
- surrealdb (crates.io): affected from 3.0.0-alpha.1; fixed in 3.0.0-beta.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63763/ (Markdown: https://insights.sbomify.com/CVE-2026-63763/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63763
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63763
- OSV: https://osv.dev/vulnerability/CVE-2026-63763

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63763/
Summaries are generated and may contain mistakes; the official description above is the record.
