{"answers":{"affected":"2 open source packages ship an affected version, including google/protobuf.","exploited":"There is no known exploitation of CVE-2026-6409 in the wild and no public exploit code.","fix":"Upgrade google/protobuf to 4.33.6 or later.","what":"CVE-2026-6409 is a high-severity denial of service vulnerability in Protocol Buffers Protobuf-php (Pecl), published on 16 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-6409 and fix it if it is affected.\n\nWhat it is: CVE-2026-6409 is a high-severity denial of service vulnerability in Protocol Buffers Protobuf-php (Pecl), published on 16 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-6409 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- google/protobuf (Packagist): affected all versions; fixed in 4.33.6\n- google/protobuf (Packagist): affected all versions; fixed in 4.33.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-6409/ (Markdown: https://insights.sbomify.com/CVE-2026-6409/index.md)","id":"CVE-2026-6409","markdown":"https://insights.sbomify.com/CVE-2026-6409/index.md","name":"CVE-2026-6409","record":{"aliases":["AZL-83420","CLSA-2026-1778633123","CLSA-2026-1787916992","DEBIAN-CVE-2026-6409","ECHO-2757-275f-4acb","GHSA-p2gh-cfq4-4wjc","UBUNTU-CVE-2026-6409","USN-8943-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Protobuf PHP library","requires_auth":"none","summary":"Attackers can crash applications using the Protobuf PHP library by sending maliciously structured messages with negative varints or deep recursion.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Google","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"A Denial of Service (DoS) vulnerability exists in the Protobuf PHP library during the parsing of untrusted input. Maliciously structured messages—specifically those containing negative varints or deep recursion—can be used to crash the application, impacting service availability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service (DoS) vulnerability exists in the Protobuf PHP library during the parsing of untrusted input","id":"CVE-2026-6409","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"@fastify/static vulnerable to path traversal in directory listing","id":"CVE-2026-6410"},"packages":[{"ecosystem":"Packagist","fixed":["4.33.6"],"introduced":["0"],"last_affected":[],"package":"google/protobuf","purl":null,"source":"GHSA-p2gh-cfq4-4wjc"},{"ecosystem":"Packagist","fixed":["4.33.6"],"introduced":["0"],"last_affected":[],"package":"google/protobuf","purl":"pkg:composer/google/protobuf","source":"GHSA-p2gh-cfq4-4wjc"}],"prev":{"headline":"Tanium addressed an information disclosure vulnerability in Tanium Server.","id":"CVE-2026-6408"},"products":["Protobuf-php (Pecl)"],"published":"2026-04-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-16","vendors":["Protocol Buffers"]},"summary":"Attackers can crash applications using the Protobuf PHP library by sending maliciously structured messages with negative varints or deep recursion.","url":"https://insights.sbomify.com/CVE-2026-6409/"}