# CVE-2026-6410: @fastify/static vulnerable to path traversal in directory listing

> An attacker can list arbitrary directories outside the static root if directory listing is enabled, disclosing file names.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Apr 2026
- **Updated:** 16 Apr 2026
- **Also known as:** GHSA-pr96-94w5-mx2h, MINI-mv5p-3p7r-8ghx

## What is CVE-2026-6410?

CVE-2026-6410 is a medium-severity path traversal vulnerability in @fastify/static, published on 16 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@fastify/static versions 8.0.0 through 9.1.0 allow path traversal when directory listing is enabled via the list option. The dirList.path() function resolves directories outside the configured static root using path.join() without a containment check. A remote unauthenticated attacker can obtain directory listings for arbitrary directories accessible to the Node.js process, disclosing directory and file names. File contents are not disclosed. Upgrade to @fastify/static 9.1.1 to fix this issue. As a workaround, disable directory listing by removing the list option from the plugin configuration.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-6410?

2 open source packages ship an affected version, including @fastify/static. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@fastify/static` | npm | From 8.0.0 | 9.1.1 |
| `@fastify/static` | npm | From 8.0.0 | 9.1.1 |

Products: Fastify Fastify-Static.

## How do I fix CVE-2026-6410?

Upgrade @fastify/static to 9.1.1 or later.

## Is CVE-2026-6410 being exploited?

There is no known exploitation of CVE-2026-6410 in the wild and no public exploit code.

## Other vulnerabilities in @fastify/static

- [CVE-2021-22964](https://insights.sbomify.com/CVE-2021-22964/): DOS and Open Redirect with user input (high 8.8)
- [CVE-2026-18427](https://insights.sbomify.com/CVE-2026-18427/): @fastify/static vulnerable to route guard bypass via non-canonical path segments (high 7.5)
- [CVE-2026-15074](https://insights.sbomify.com/CVE-2026-15074/): @fastify/static vulnerable to route guard bypass via path traversal (high 7.5)
- [CVE-2021-22963](https://insights.sbomify.com/CVE-2021-22963/): URL Redirection to Untrusted Site ('Open Redirect') in fastify-static (medium 6.1)
- [CVE-2026-6414](https://insights.sbomify.com/CVE-2026-6414/): @fastify/static vulnerable to route guard bypass via encoded path separators (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6410 and fix it if it is affected.

What it is: CVE-2026-6410 is a medium-severity path traversal vulnerability in @fastify/static, published on 16 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6410 in the wild and no public exploit code.

Affected packages and fixed versions:
- @fastify/static (npm): affected from 8.0.0; fixed in 9.1.1
- @fastify/static (npm): affected from 8.0.0; fixed in 9.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6410/ (Markdown: https://insights.sbomify.com/CVE-2026-6410/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6410
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6410
- OSV: https://osv.dev/vulnerability/CVE-2026-6410

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6410/
Summaries are generated and may contain mistakes; the official description above is the record.
