CVE-2026-6414 @fastify/static vulnerable to route guard bypass via encoded path separators

Medium 5.9 Published Updated

Attackers can bypass route guards protecting static files by using encoded path separators, requiring an upgrade to the @fastify/static library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-6414?

CVE-2026-6414 is a medium-severity vulnerability in @fastify/static, published on 16 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

@fastify/static versions 8.0.0 through 9.1.0 decode percent-encoded path separators (%2F) before filesystem resolution, while Fastify's router treats them as literal characters. This mismatch allows attackers to bypass route-based middleware or guards that protect files served by @fastify/static. For example, a route guard on a protected path can be circumvented by encoding the path separator in the URL. Upgrade to @fastify/static 9.1.1 to fix this issue. There are no workarounds.

Weakness: CWE-177

Which versions are affected by CVE-2026-6414?

2 open source packages ship an affected version, including @fastify/static. It affects 1 product.

PackageAffectedFixed in
@fastify/static npmFrom 8.0.09.1.1
@fastify/static npmFrom 8.0.09.1.1

Products include Fastify Fastify-Static.

How do I fix CVE-2026-6414?

Upgrade @fastify/static to 9.1.1 or later.

Is CVE-2026-6414 being exploited?

There is no known exploitation of CVE-2026-6414 in the wild and no public exploit code.

Sources

Also known as GHSA-x428-ghpx-8j92, MINI-r7q9-h4q3-pgj5.

Is CVE-2026-6414 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free