# CVE-2026-6414: @fastify/static vulnerable to route guard bypass via encoded path separators

> Attackers can bypass route guards protecting static files by using encoded path separators, requiring an upgrade to the @fastify/static library.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Apr 2026
- **Updated:** 16 Apr 2026
- **Also known as:** GHSA-x428-ghpx-8j92, MINI-r7q9-h4q3-pgj5

## What is CVE-2026-6414?

CVE-2026-6414 is a medium-severity vulnerability in @fastify/static, published on 16 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@fastify/static versions 8.0.0 through 9.1.0 decode percent-encoded path separators (%2F) before filesystem resolution, while Fastify's router treats them as literal characters. This mismatch allows attackers to bypass route-based middleware or guards that protect files served by @fastify/static. For example, a route guard on a protected path can be circumvented by encoding the path separator in the URL. Upgrade to @fastify/static 9.1.1 to fix this issue. There are no workarounds.

Weakness: CWE-177 (Improper Handling of URL Encoding (Hex Encoding))

## Which versions are affected by CVE-2026-6414?

2 open source packages ship an affected version, including @fastify/static. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@fastify/static` | npm | From 8.0.0 | 9.1.1 |
| `@fastify/static` | npm | From 8.0.0 | 9.1.1 |

Products: Fastify Fastify-Static.

## How do I fix CVE-2026-6414?

Upgrade @fastify/static to 9.1.1 or later.

## Is CVE-2026-6414 being exploited?

There is no known exploitation of CVE-2026-6414 in the wild and no public exploit code.

## Other vulnerabilities in @fastify/static

- [CVE-2021-22964](https://insights.sbomify.com/CVE-2021-22964/): DOS and Open Redirect with user input (high 8.8)
- [CVE-2026-18427](https://insights.sbomify.com/CVE-2026-18427/): @fastify/static vulnerable to route guard bypass via non-canonical path segments (high 7.5)
- [CVE-2026-15074](https://insights.sbomify.com/CVE-2026-15074/): @fastify/static vulnerable to route guard bypass via path traversal (high 7.5)
- [CVE-2021-22963](https://insights.sbomify.com/CVE-2021-22963/): URL Redirection to Untrusted Site ('Open Redirect') in fastify-static (medium 6.1)
- [CVE-2026-7120](https://insights.sbomify.com/CVE-2026-7120/): @fastify/static vulnerable to Authorization Bypass via Non-Canonical URL Paths (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6414 and fix it if it is affected.

What it is: CVE-2026-6414 is a medium-severity vulnerability in @fastify/static, published on 16 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6414 in the wild and no public exploit code.

Affected packages and fixed versions:
- @fastify/static (npm): affected from 8.0.0; fixed in 9.1.1
- @fastify/static (npm): affected from 8.0.0; fixed in 9.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6414/ (Markdown: https://insights.sbomify.com/CVE-2026-6414/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6414
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6414
- OSV: https://osv.dev/vulnerability/CVE-2026-6414

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6414/
Summaries are generated and may contain mistakes; the official description above is the record.
