# CVE-2026-6420: Keylime: keylime: security bypass due to hardcoded tpm quote nonce

> Attackers with root access can bypass TPM attestation in Keylime push model deployments by replaying quotes due to a hardcoded nonce.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 May 2026
- **Updated:** 26 Aug 2026
- **Also known as:** ALSA-2026:28582, GHSA-q8w6-w55c-ccv5, PYSEC-2026-2548, RHSA-2026:28582, RLSA-2026:28582, SUSE-SU-2026:22326-1, openSUSE-SU-2026:10779-1, openSUSE-SU-2026:21025-1

## What is CVE-2026-6420?

CVE-2026-6420 is a medium-severity vulnerability in Red Hat Enterprise Linux 10, published on 6 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A flaw was found in Keylime. An attacker with root access on an enrolled monitored machine, where the Keylime agent runs, can exploit a vulnerability in the Keylime verifier. The verifier uses a hardcoded challenge nonce for Trusted Platform Module (TPM) quote attestation instead of a cryptographically random value. This allows the attacker to stockpile valid TPM quotes and replay them to evade detection after compromising the system. This issue affects only the push model deployment.

Weakness: CWE-1241 (Use of Predictable Algorithm in Random Number Generator)

## Which versions are affected by CVE-2026-6420?

3 open source packages ship an affected version, including keylime.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keylime` | PyPI | From 7.14.0 | 7.14.2 |
| `keylime` | PyPI | From 7.14.0 | 7.14.2 |
| `keylime` | PyPI | From 7.14.0 | 7.14.2 |
| `keylime` | AlmaLinux:10 | All versions | 7.14.1-5.el10_2.1 |
| `keylime-base` | AlmaLinux:10 | All versions | 7.14.1-5.el10_2.1 |
| `keylime-registrar` | AlmaLinux:10 | All versions | 7.14.1-5.el10_2.1 |
| `keylime-selinux` | AlmaLinux:10 | All versions | 7.14.1-5.el10_2.1 |
| `keylime-tenant` | AlmaLinux:10 | All versions | 7.14.1-5.el10_2.1 |
| `keylime-tools` | AlmaLinux:10 | All versions | 7.14.1-5.el10_2.1 |
| `keylime-verifier` | AlmaLinux:10 | All versions | 7.14.1-5.el10_2.1 |
| `python3-keylime` | AlmaLinux:10 | All versions | 7.14.1-5.el10_2.1 |
| `keylime` | Red Hat:enterprise_linux:10.2 | All versions | 0:7.14.1-5.el10_2.1 |
| `keylime-base` | Red Hat:enterprise_linux:10.2 | All versions | 0:7.14.1-5.el10_2.1 |
| `keylime-registrar` | Red Hat:enterprise_linux:10.2 | All versions | 0:7.14.1-5.el10_2.1 |
| `keylime-selinux` | Red Hat:enterprise_linux:10.2 | All versions | 0:7.14.1-5.el10_2.1 |
| `keylime-tenant` | Red Hat:enterprise_linux:10.2 | All versions | 0:7.14.1-5.el10_2.1 |
| `keylime-tools` | Red Hat:enterprise_linux:10.2 | All versions | 0:7.14.1-5.el10_2.1 |
| `keylime-verifier` | Red Hat:enterprise_linux:10.2 | All versions | 0:7.14.1-5.el10_2.1 |
| `python3-keylime` | Red Hat:enterprise_linux:10.2 | All versions | 0:7.14.1-5.el10_2.1 |
| `keylime` | Rocky Linux:10 | All versions | 0:7.14.1-5.el10_2.1 |
| `keylime` | SUSE:Linux Enterprise Server 16.0 | All versions | 7.14.2-160000.1.1 |
| `keylime` | SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 7.14.2-160000.1.1 |
| `keylime` | openSUSE:Leap 16.0 | All versions | 7.14.2-160000.1.1 |
| `keylime` | openSUSE:Tumbleweed | All versions | 7.14.2-1.1 |

## How do I fix CVE-2026-6420?

Upgrade keylime to 7.14.2 or later.

## Is CVE-2026-6420 being exploited?

There is no known exploitation of CVE-2026-6420 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6420 and fix it if it is affected.

What it is: CVE-2026-6420 is a medium-severity vulnerability in Red Hat Enterprise Linux 10, published on 6 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6420 in the wild and no public exploit code.

Affected packages and fixed versions:
- keylime (PyPI): affected from 7.14.0; fixed in 7.14.2
- keylime (PyPI): affected from 7.14.0; fixed in 7.14.2
- keylime (PyPI): affected from 7.14.0; fixed in 7.14.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6420/ (Markdown: https://insights.sbomify.com/CVE-2026-6420/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6420
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6420
- OSV: https://osv.dev/vulnerability/CVE-2026-6420

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6420/
Summaries are generated and may contain mistakes; the official description above is the record.
