CVE-2026-6437 AWS EFS CSI Driver Mount Option Injection
Authenticated users with volume creation permissions can inject mount options to execute arbitrary commands or escalate privileges in the AWS EFS CSI Driver.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-6437?
CVE-2026-6437 is a medium-severity command injection vulnerability in Amazon AWS EFS CSI Driver, published on 17 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Improper neutralization of argument delimiters in the volume handling component in AWS EFS CSI Driver (aws-efs-csi-driver) before v3.0.1 allows remote authenticated users with PersistentVolume creation permissions to inject arbitrary mount options via comma injection.
To remediate this issue, users should upgrade to version v3.0.1
Weakness: CWE-88
Which versions are affected by CVE-2026-6437?
2 open source packages ship an affected version, including github.com/kubernetes-sigs/aws-efs-csi-driver. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/kubernetes-sigs/aws-efs-csi-driver Go | All versions | 1.7.8-0.20260416142831-51806c22c575 |
github.com/kubernetes-sigs/aws-efs-csi-driver Go | All versions | 1.7.8-0.20260416142831-51806c22c575 |
Products include Amazon Efs Csi Driver.
How do I fix CVE-2026-6437?
Upgrade github.com/kubernetes-sigs/aws-efs-csi-driver to 1.7.8-0.20260416142831-51806c22c575 or later.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2026-6437 being exploited?
There is no known exploitation of CVE-2026-6437 in the wild and no public exploit code.
Sources
Also known as ECHO-8474-6973-caee, GHSA-mph4-q2vm-w2pw.