{"answers":{"affected":"2 open source packages ship an affected version, including github.com/kubernetes-sigs/aws-efs-csi-driver. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-6437 in the wild and no public exploit code.","fix":"Upgrade github.com/kubernetes-sigs/aws-efs-csi-driver to 1.7.8-0.20260416142831-51806c22c575 or later.","what":"CVE-2026-6437 is a medium-severity command injection vulnerability in Amazon AWS EFS CSI Driver, published on 17 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-6437 and fix it if it is affected.\n\nWhat it is: CVE-2026-6437 is a medium-severity command injection vulnerability in Amazon AWS EFS CSI Driver, published on 17 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-6437 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/kubernetes-sigs/aws-efs-csi-driver (Go): affected all versions; fixed in 1.7.8-0.20260416142831-51806c22c575\n- github.com/kubernetes-sigs/aws-efs-csi-driver (Go): affected all versions; fixed in 1.7.8-0.20260416142831-51806c22c575\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-6437/ (Markdown: https://insights.sbomify.com/CVE-2026-6437/index.md)","id":"CVE-2026-6437","markdown":"https://insights.sbomify.com/CVE-2026-6437/index.md","name":"CVE-2026-6437","record":{"aliases":["ECHO-8474-6973-caee","GHSA-mph4-q2vm-w2pw"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"AWS EFS CSI Driver","requires_auth":"high_privilege","summary":"Authenticated users with volume creation permissions can inject mount options to execute arbitrary commands or escalate privileges in the AWS EFS CSI Driver.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"AMZN","cpe":[{"product":"efs_csi_driver","vendor":"amazon"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:H/VA:N/SC:H/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"}],"description":"Improper neutralization of argument delimiters in the volume handling component in AWS EFS CSI Driver (aws-efs-csi-driver) before v3.0.1 allows remote authenticated users with PersistentVolume creation permissions to inject arbitrary mount options via comma injection.\n\nTo remediate this issue, users should upgrade to version v3.0.1","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"AWS EFS CSI Driver Mount Option Injection","id":"CVE-2026-6437","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Cross-site scripting in VideoZen","id":"CVE-2026-6439"},"packages":[{"ecosystem":"Go","fixed":["1.7.8-0.20260416142831-51806c22c575"],"introduced":["0"],"last_affected":[],"package":"github.com/kubernetes-sigs/aws-efs-csi-driver","purl":null,"source":"GHSA-mph4-q2vm-w2pw"},{"ecosystem":"Go","fixed":["1.7.8-0.20260416142831-51806c22c575"],"introduced":["0"],"last_affected":[],"package":"github.com/kubernetes-sigs/aws-efs-csi-driver","purl":"pkg:golang/github.com/kubernetes-sigs/aws-efs-csi-driver","source":"GHSA-mph4-q2vm-w2pw"}],"prev":{"headline":"Custom CSS JS PHP \u003c= 2.0.7 - Unauthenticated SQL Injection to RCE","id":"CVE-2026-6433"},"products":["AWS EFS CSI Driver"],"published":"2026-04-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-20","vendors":["Amazon"]},"summary":"Authenticated users with volume creation permissions can inject mount options to execute arbitrary commands or escalate privileges in the AWS EFS CSI Driver.","url":"https://insights.sbomify.com/CVE-2026-6437/"}