# CVE-2026-6437: AWS EFS CSI Driver Mount Option Injection

> Authenticated users with volume creation permissions can inject mount options to execute arbitrary commands or escalate privileges in the AWS EFS CSI Driver.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:H/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2026
- **Updated:** 20 Oct 2026
- **Also known as:** ECHO-8474-6973-caee, GHSA-mph4-q2vm-w2pw

## What is CVE-2026-6437?

CVE-2026-6437 is a medium-severity command injection vulnerability in Amazon AWS EFS CSI Driver, published on 17 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Improper neutralization of argument delimiters in the volume handling component in AWS EFS CSI Driver (aws-efs-csi-driver) before v3.0.1 allows remote authenticated users with PersistentVolume creation permissions to inject arbitrary mount options via comma injection.

To remediate this issue, users should upgrade to version v3.0.1

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2026-6437?

2 open source packages ship an affected version, including github.com/kubernetes-sigs/aws-efs-csi-driver. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kubernetes-sigs/aws-efs-csi-driver` | Go | All versions | 1.7.8-0.20260416142831-51806c22c575 |
| `github.com/kubernetes-sigs/aws-efs-csi-driver` | Go | All versions | 1.7.8-0.20260416142831-51806c22c575 |

Products: Amazon Efs Csi Driver.

## How do I fix CVE-2026-6437?

Upgrade github.com/kubernetes-sigs/aws-efs-csi-driver to 1.7.8-0.20260416142831-51806c22c575 or later.

## Is CVE-2026-6437 being exploited?

There is no known exploitation of CVE-2026-6437 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6437 and fix it if it is affected.

What it is: CVE-2026-6437 is a medium-severity command injection vulnerability in Amazon AWS EFS CSI Driver, published on 17 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6437 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/kubernetes-sigs/aws-efs-csi-driver (Go): affected all versions; fixed in 1.7.8-0.20260416142831-51806c22c575
- github.com/kubernetes-sigs/aws-efs-csi-driver (Go): affected all versions; fixed in 1.7.8-0.20260416142831-51806c22c575

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6437/ (Markdown: https://insights.sbomify.com/CVE-2026-6437/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6437
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6437
- OSV: https://osv.dev/vulnerability/CVE-2026-6437

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6437/
Summaries are generated and may contain mistakes; the official description above is the record.
