CVE-2026-64608 Apache Fory: Heap type confusion and out-of-bounds read/write in C++ compatible-mode field-skip paths

Critical 9.8 Published Updated

Attackers can trigger heap type confusion and out-of-bounds memory access in Apache Fory C++ by sending crafted serialized data in compatible mode.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-64608?

CVE-2026-64608 is a critical unsafe deserialization vulnerability in Apache Fory, published on 21 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Heap type confusion and out-of-bounds read/write in the Apache Fory C++ implementation. When deserializing data in compatible mode, the field-skip paths do not correctly validate the declared field types against the actual data, so input with an inconsistent schema can cause type confusion and out-of-bounds memory access. Only the C++ implementation is affected; other language implementations of Apache Fory are not.

This issue affects Apache Fory C++: from 0.14.0 before 1.4.0.

Users are recommended to upgrade to version 1.4.0, which fixes the issue.

Weakness: CWE-843, CWE-787, CWE-502

Which versions are affected by CVE-2026-64608?

It affects 1 product.

Products include Apache Fory.

How do I fix CVE-2026-64608?

No fix has been published for CVE-2026-64608 yet. Limit exposure of the affected software until one is available.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2026-64608 being exploited?

There is no known exploitation of CVE-2026-64608 in the wild and no public exploit code.

Sources

Also known as GHSA-wh2x-66qr-23v8.

Is CVE-2026-64608 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free