CVE-2026-64610 Apache Kylin: Redis unsafe Java deserialization

Critical 9.8 Published Updated

An attacker can execute arbitrary code via unsafe Java deserialization from a broken external cache service in Apache Kylin.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-64610?

CVE-2026-64610 is a critical unsafe deserialization vulnerability in Apache Kylin, published on 16 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Deserialization of Untrusted Data vulnerability in Apache Kylin. Unsafe Java deserialization could happen from a broken external cache service.

This issue affects Apache Kylin: from 4 through 5.0.4.

Users are recommended to upgrade to version 5.0.5, which fixes the issue.

Weakness: CWE-502

Which versions are affected by CVE-2026-64610?

How do I fix CVE-2026-64610?

No fix has been published for CVE-2026-64610 yet. Limit exposure of the affected software until one is available.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2026-64610 being exploited?

There is no known exploitation of CVE-2026-64610 in the wild and no public exploit code.

Sources

Also known as GHSA-qxq5-8286-84xg.

Is CVE-2026-64610 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free