# CVE-2026-6464: PostgreSQL psql COPY FROM STDIN early failure processes data lines as psql commands

> Attackers can execute arbitrary psql commands by triggering early COPY failures, requiring control over server errors and data rows.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 29 Aug 2026
- **Also known as:** ALPINE-CVE-2026-6464, AZL-95741, BELL-CVE-2026-6464, BIT-postgresql-2026-6464, DEBIAN-CVE-2026-6464, ECHO-930d-ab3a-f99c, GHSA-j447-m374-x28h, MINI-2c49-x6gv-455h, MINI-3pfw-vqr7-qx92, MINI-4x3m-xqc6-3975, MINI-5cq6-j4cc-g84v, MINI-9qjm-h937-6f9h, MINI-mppw-v5q8-xwq2, ROOT-OS-DEBIAN-11-CVE-2026-6464, UBUNTU-CVE-2026-6464

## What is CVE-2026-6464?

CVE-2026-6464 is a high-severity code injection vulnerability in Postgresql Postgresql, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Untrusted data inclusion in PostgreSQL psql COPY may allow a server administrator to elicit execution of data lines as psql commands, via error injection.  If the "COPY FROM STDIN" or "\copy FROM STDIN" command fails before the server indicates that it awaits input rows, psql processes the in-line data rows as psql commands.  "COPY FROM" with a filename is unaffected.  The server administrator has no inherent control over the data rows, so a complete attack requires the attacker to separately acquire control of both the server and the data rows.  Alternatively, an attacker controlling data rows alone might complete an attack through a coincidental error that they don't control.  Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere)

## Which versions are affected by CVE-2026-6464?

1 open source package ship an affected version, including postgresql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | All versions | 14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0 |

Products: Postgresql Postgresql.

## How do I fix CVE-2026-6464?

Upgrade postgresql to a fixed version for your release line: 14.24.0, 15.19.0, 16.15.0 or 17.11.0.

## Is CVE-2026-6464 being exploited?

There is no known exploitation of CVE-2026-6464 in the wild and no public exploit code.

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6464 and fix it if it is affected.

What it is: CVE-2026-6464 is a high-severity code injection vulnerability in Postgresql Postgresql, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6464 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected all versions; fixed in 14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6464/ (Markdown: https://insights.sbomify.com/CVE-2026-6464/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6464
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6464
- OSV: https://osv.dev/vulnerability/CVE-2026-6464

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6464/
Summaries are generated and may contain mistakes; the official description above is the record.
