# CVE-2026-64640: Apache Polaris: register endpoint reads attacker-controlled storage location before allowed-locations validation

> Authenticated users can bypass storage location validation to read unauthorized Iceberg metadata files via the register endpoint.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/S:N/U:Clear`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2026
- **Updated:** 6 Aug 2026
- **Also known as:** GHSA-62q9-5g2h-5gxp, MINI-67hp-c4vr-542x, MINI-7h5v-q44v-vvx6, MINI-7vm2-cg86-f77q, MINI-fm65-hggj-v5j2, PYSEC-2026-3623

## What is CVE-2026-64640?

CVE-2026-64640 is a medium-severity missing authorization vulnerability in Apache Polaris, published on 6 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Polaris did not consistently validate storage locations supplied during table and view registration.

An authenticated principal with permission to register a table or view could, depending on the affected release and registration path, cause Polaris to use the catalog's storage credentials to read a caller-selected Iceberg metadata file before verifying that the file was within the catalog's allowed storage locations.

If the catalog's underlying credentials could read an object outside that boundary, this could disclose limited information from the object.

Polaris could also accept registration metadata located within an allowed location that contained references to storage locations outside the allowed boundary.

This second condition did not itself cause Polaris to read the referenced external locations during registration.

The demonstrated impact is limited to confidentiality.

No unauthorized data modification or availability impact has been demonstrated.

The server-side read requires a deployment using S3 credential vending and an object outside the allowed locations that the catalog's underlying storage credentials can read.

Exploitation requires an authenticated principal with table- or view-registration privileges.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-64640?

1 open source package ship an affected version, including apache-polaris. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-polaris` | PyPI | All versions | 1.7.0 |

Products: Apache Polaris.

## How do I fix CVE-2026-64640?

Upgrade apache-polaris to 1.7.0 or later.

## Is CVE-2026-64640 being exploited?

There is no known exploitation of CVE-2026-64640 in the wild and no public exploit code.

Public exploit code:

- Reproducer for CVE-2026-64640 — Apache Polaris Iceberg REST register/register-view vends storage credentials and reads an attacker-chosen metadata location before validating allowedLocations (confused-deputy cross-tenant read). Affected ≤ 1.6.0, fixed in 1.7.0. (github_poc): https://github.com/oscerd/CVE-2026-64640

## Other vulnerabilities in Apache Polaris

- [CVE-2026-42809](https://insights.sbomify.com/CVE-2026-42809/): Apache Polaris: staged table creation could vend storage credentials for unvalidated locations (critical 9.4)
- [CVE-2026-42810](https://insights.sbomify.com/CVE-2026-42810/): Apache Polaris: could broaden vended S3 credentials through wildcard-bearing namespace or table names (critical 9.4)
- [CVE-2026-42811](https://insights.sbomify.com/CVE-2026-42811/): Apache Polaris has an Improper Input Validation issue (critical 9.4)
- [CVE-2026-42812](https://insights.sbomify.com/CVE-2026-42812/): Apache Polaris: No protection on `write.metadata.path` (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-64640 and fix it if it is affected.

What it is: CVE-2026-64640 is a medium-severity missing authorization vulnerability in Apache Polaris, published on 6 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-64640 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-polaris (PyPI): affected all versions; fixed in 1.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-64640/ (Markdown: https://insights.sbomify.com/CVE-2026-64640/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-64640
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-64640
- OSV: https://osv.dev/vulnerability/CVE-2026-64640

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-64640/
Summaries are generated and may contain mistakes; the official description above is the record.
