# CVE-2026-64643: Next.js: Unauthenticated Disclosure of Internal Server Function endpoints

> Unauthenticated attackers can disclose internal Server Action endpoints in Next.js App Router applications, bypassing page-level authentication controls.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2026
- **Updated:** 27 Jul 2026
- **Also known as:** CLEANSTART-2026-BM18336, CLEANSTART-2026-LF50543, ECHO-9c66-41a7-0eec, GHSA-955p-x3mx-jcvp, MINI-2fx4-j5jv-6p5h, MINI-4cg3-rc6f-xg6p, MINI-mm9v-633h-h5p5, MINI-rg9x-rv52-q5p8, ROOT-APP-NPM-CVE-2026-64643

## What is CVE-2026-64643?

CVE-2026-64643 is a medium-severity vulnerability in Vercel Next.js, published on 27 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Next.js is a React framework for building full-stack web applications. In versions 12.0.0 through 15.5.20 and 16.0.0 through 16.2.10, Next.js applications using App Router, Server Actions (use server) or use cache endpoints can be disclosed bypassing any authentication on the pages where these endpoints are usually used. Server Action IDs can be disclosed to unauthenticated users via publicly served client artifacts (for example, static chunks containing action references). Affected users are applications using App Router and Server Actions. By itself, this disclosure is typically a recon/enumeration primitive; however, it can increase risk when combined with other weaknesses. This issue has been fixed in versions 15.5.21 and 16.2.11.

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2026-64643?

4 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 13.0.0 | 15.5.21 |
| `next` | npm | From 13.0.0 | 15.5.21 |
| `next` | npm | From 16.0.0 | 16.2.11 |
| `next` | npm | From 16.0.0 | 16.2.11 |

Products: Vercel Next.js.

## How do I fix CVE-2026-64643?

Upgrade next to a fixed version for your release line: 15.5.21 or 16.2.11.

## Is CVE-2026-64643 being exploited?

There is no known exploitation of CVE-2026-64643 in the wild and no public exploit code.

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-64643 and fix it if it is affected.

What it is: CVE-2026-64643 is a medium-severity vulnerability in Vercel Next.js, published on 27 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-64643 in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 13.0.0; fixed in 15.5.21
- next (npm): affected from 13.0.0; fixed in 15.5.21
- next (npm): affected from 16.0.0; fixed in 16.2.11
- next (npm): affected from 16.0.0; fixed in 16.2.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-64643/ (Markdown: https://insights.sbomify.com/CVE-2026-64643/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-64643
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-64643
- OSV: https://osv.dev/vulnerability/CVE-2026-64643

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-64643/
Summaries are generated and may contain mistakes; the official description above is the record.
