# CVE-2026-64645: Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname

> Attackers can exploit Next.js rewrites to perform Server-Side Request Forgery or Open Redirects by controlling destination hostnames, requiring specific rewrite configurations.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2026
- **Updated:** 28 Jul 2026
- **Also known as:** CLEANSTART-2026-SY86267, CLEANSTART-2026-YT06391, CLSA-2026-1792195729, CLSA-2026-1792196879, CLSA-2026-1792206306, CLSA-2026-1792272247, CLSA-2026-1792293018, CLSA-2026-1792304722, CLSA-2026-1792326310, CLSA-2026-1792338237, CLSA-2026-1792358603, CLSA-2026-1792364011, ECHO-5188-d20a-988b, GHSA-p9j2-gv94-2wf4, MINI-8h3w-75f7-75p6, MINI-9rmh-pc8w-h98g, MINI-c4hp-62hj-88hx, MINI-pfx4-3jqv-gm5f, ROOT-APP-NPM-CVE-2026-64645

## What is CVE-2026-64645?

CVE-2026-64645 is a high-severity server-side request forgery vulnerability in Vercel Next.js, published on 27 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Next.js is a React framework for building full-stack web applications. In versions 12.0.0 through 15.5.20 and 16.0.0 through 16.2.10, a
 rewrites() or redirects() rule that builds its external destination hostname from request-controlled input can be pointed at an arbitrary hostname, regardless of the rule's hostname suffix. For a rewrite, Next.js proxies the request to that arbitrary host and serves the response from the application's origin, leading to Server-Side Request forgery. A redirects() rule configured this way is vulnerable to an Open Redirect. This issue has been fixed in versions 15.5.21 and 16.2.11.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-64645?

4 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 12.0.0 | 15.5.21 |
| `next` | npm | From 12.0.0 | 15.5.21 |
| `next` | npm | From 16.0.0 | 16.2.11 |
| `next` | npm | From 16.0.0 | 16.2.11 |

Products: Vercel Next.js.

## How do I fix CVE-2026-64645?

Upgrade next to a fixed version for your release line: 15.5.21 or 16.2.11.

## Is CVE-2026-64645 being exploited?

There is no known exploitation of CVE-2026-64645 in the wild and no public exploit code.

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64649](https://insights.sbomify.com/CVE-2026-64649/): Next.js: Server-Side Request Forgery in Server Actions on Custom Servers (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-64645 and fix it if it is affected.

What it is: CVE-2026-64645 is a high-severity server-side request forgery vulnerability in Vercel Next.js, published on 27 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-64645 in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 12.0.0; fixed in 15.5.21
- next (npm): affected from 12.0.0; fixed in 15.5.21
- next (npm): affected from 16.0.0; fixed in 16.2.11
- next (npm): affected from 16.0.0; fixed in 16.2.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-64645/ (Markdown: https://insights.sbomify.com/CVE-2026-64645/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-64645
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-64645
- OSV: https://osv.dev/vulnerability/CVE-2026-64645

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-64645/
Summaries are generated and may contain mistakes; the official description above is the record.
