# CVE-2026-64647: Next.js: Response Body Cache Confusion with Invalid UTF-8 Request Bodies

> Attackers can leak confidential response data by exploiting cache confusion with invalid UTF-8 request bodies in Next.js server-side fetches.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2026
- **Updated:** 27 Jul 2026
- **Also known as:** CLEANSTART-2026-HD84231, CLEANSTART-2026-QW21526, ECHO-8f20-024b-f6f8, GHSA-4633-3j49-mh5q, MINI-2g92-9prq-rr67, MINI-4cxc-m35w-4hxp, MINI-gm5f-9cgh-23f6, MINI-wwj3-7gc5-v485, ROOT-APP-NPM-CVE-2026-64647

## What is CVE-2026-64647?

CVE-2026-64647 is a medium-severity vulnerability in Vercel Next.js, published on 27 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Next.js is a React framework for building full-stack web applications. In versions 12.0.0 through 15.5.20 and 16.0.0 through 16.2.10, a server-side fetch with a request body may return a cached response body from a different request to the same URL but different body. Confidential data in the POST's response body would then leak to unauthorized requests. Though the request itself will not be deduped. This is only an issue when receiving request bodies with a content type charset other than UTF-8. For example, the UTF-16 byte sequences for 삃삃 and 섄섄 in the request body would share the same cache. This issue has been fixed in versions 15.5.21 and 16.2.11.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-64647?

4 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 13.0.0 | 15.5.21 |
| `next` | npm | From 13.0.0 | 15.5.21 |
| `next` | npm | From 16.0.0 | 16.2.11 |
| `next` | npm | From 16.0.0 | 16.2.11 |

Products: Vercel Next.js.

## How do I fix CVE-2026-64647?

Upgrade next to a fixed version for your release line: 15.5.21 or 16.2.11.

## Is CVE-2026-64647 being exploited?

There is no known exploitation of CVE-2026-64647 in the wild and no public exploit code.

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-64647 and fix it if it is affected.

What it is: CVE-2026-64647 is a medium-severity vulnerability in Vercel Next.js, published on 27 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-64647 in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 13.0.0; fixed in 15.5.21
- next (npm): affected from 13.0.0; fixed in 15.5.21
- next (npm): affected from 16.0.0; fixed in 16.2.11
- next (npm): affected from 16.0.0; fixed in 16.2.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-64647/ (Markdown: https://insights.sbomify.com/CVE-2026-64647/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-64647
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-64647
- OSV: https://osv.dev/vulnerability/CVE-2026-64647

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-64647/
Summaries are generated and may contain mistakes; the official description above is the record.
