# CVE-2026-64649: Next.js: Server-Side Request Forgery in Server Actions on Custom Servers

> Attackers can force Next.js servers to send requests to malicious hosts via Server Actions, potentially exposing internal data or bypassing authorization.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2026
- **Updated:** 28 Jul 2026
- **Also known as:** CLEANSTART-2026-KK18205, CLEANSTART-2026-KT00157, ECHO-0663-1480-e28f, GHSA-89xv-2m56-2m9x, MINI-cc4r-gw7f-xjv3, MINI-rfmj-vrxv-65xj, MINI-wvp9-r7g5-2cxx, MINI-xxp8-r676-33v7, ROOT-APP-NPM-CVE-2026-64649

## What is CVE-2026-64649?

CVE-2026-64649 is a high-severity server-side request forgery vulnerability in Vercel Next.js, published on 27 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Next.js is a React framework for building full-stack web applications. In versions 14.1.1 through 15.5.20 and 16.0.0 through 16.2.10, when a Server Action forwards or redirects a request, an attacker can cause the server to send that outbound request to a malicious host (Server-Side Request Forgery). This requires the attacker's request to control Host-associated headers. In some configurations, it's also possible to obtain internal values that weaken middleware/proxy authorization. Applications that use Server Actions are affected when the incoming host header is not fixed to a trusted value. This typically occurs on custom servers, or on deployments not behind a proxy that pins the host. Managed hosting pins the host upstream and is not affected; next start and standalone output do the same from version 14.2 onward. This issue has been fixed in versions 15.5.21 and 16.2.11.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-64649?

4 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 14.1.1 | 15.5.21 |
| `next` | npm | From 14.1.1 | 15.5.21 |
| `next` | npm | From 16.0.0 | 16.2.11 |
| `next` | npm | From 16.0.0 | 16.2.11 |

Products: Vercel Next.js.

## How do I fix CVE-2026-64649?

Upgrade next to a fixed version for your release line: 15.5.21 or 16.2.11.

## Is CVE-2026-64649 being exploited?

There is no known exploitation of CVE-2026-64649 in the wild and no public exploit code.

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-64649 and fix it if it is affected.

What it is: CVE-2026-64649 is a high-severity server-side request forgery vulnerability in Vercel Next.js, published on 27 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-64649 in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 14.1.1; fixed in 15.5.21
- next (npm): affected from 14.1.1; fixed in 15.5.21
- next (npm): affected from 16.0.0; fixed in 16.2.11
- next (npm): affected from 16.0.0; fixed in 16.2.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-64649/ (Markdown: https://insights.sbomify.com/CVE-2026-64649/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-64649
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-64649
- OSV: https://osv.dev/vulnerability/CVE-2026-64649

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-64649/
Summaries are generated and may contain mistakes; the official description above is the record.
