# CVE-2026-64657: Budibase: Database Connector SQL Injections in PostgreSQL, MS SQL, and MySQL

> An authenticated administrator can execute arbitrary SQL via unescaped schema fields in the PostgreSQL connector, impacting data integrity and confidentiality.

- **Severity:** High 8.4 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 17 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-qqf5-x7mj-v43p

## What is CVE-2026-64657?

CVE-2026-64657 is a high-severity SQL injection vulnerability in budibase, published on 17 Aug 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Budibase is an open-source low-code platform. Prior to 3.39.19, the PostgreSQL datasource connector in packages/server/src/integrations/postgres.ts interpolates the user-controlled schema configuration field into a SET search_path statement without escaping embedded double quotes, allowing an authenticated administrator who saves or tests the datasource to execute arbitrary SQL through the simple query protocol. This issue is fixed in version 3.39.19.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-64657?

2 open source packages ship an affected version, including budibase.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `budibase` | npm | All versions | 3.39.19 |
| `budibase` | npm | All versions | 3.39.19 |

## How do I fix CVE-2026-64657?

Upgrade budibase to 3.39.19 or later.

## Is CVE-2026-64657 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-64657 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-64657 and fix it if it is affected.

What it is: CVE-2026-64657 is a high-severity SQL injection vulnerability in budibase, published on 17 Aug 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-64657 exists.

Affected packages and fixed versions:
- budibase (npm): affected all versions; fixed in 3.39.19
- budibase (npm): affected all versions; fixed in 3.39.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-64657/ (Markdown: https://insights.sbomify.com/CVE-2026-64657/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-64657
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-64657
- OSV: https://osv.dev/vulnerability/CVE-2026-64657

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-64657/
Summaries are generated and may contain mistakes; the official description above is the record.
