CVE-2026-64663 Statamic: Unsafe method invocation via Antlers template resolution allows data destruction
Unauthenticated attackers can destroy content and assets by injecting unsafe method calls into Antlers templates if untrusted input is passed to them.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-64663?
CVE-2026-64663 is a medium-severity code injection vulnerability in statamic cms, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Statamic is a Laravel and Git powered content management system (CMS). Prior to 5.74.1 and 6.24.0, manipulating user-supplied input incorporated into Antlers templates could result in the loss of content and assets, on sites whose templates pass untrusted input into affected areas, and exploitation did not require authentication. This issue is fixed in versions 5.74.1 and 6.24.0.
Weakness: CWE-470
Which versions are affected by CVE-2026-64663?
4 open source packages ship an affected version, including statamic/cms.
| Package | Affected | Fixed in |
|---|---|---|
statamic/cms Packagist | All versions | 5.74.1 |
statamic/cms Packagist | All versions | 5.74.1 |
statamic/cms Packagist | From 6.0.0 | 6.24.0 |
statamic/cms Packagist | From 6.0.0 | 6.24.0 |
How do I fix CVE-2026-64663?
Upgrade statamic/cms to a fixed version for your release line: 5.74.1 or 6.24.0.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-64663 being exploited?
There is no known exploitation of CVE-2026-64663 in the wild and no public exploit code.
Sources
Also known as GHSA-j2vp-f2pv-5rj4.