# CVE-2026-64663: Statamic: Unsafe method invocation via Antlers template resolution allows data destruction

> Unauthenticated attackers can destroy content and assets by injecting unsafe method calls into Antlers templates if untrusted input is passed to them.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2026
- **Updated:** 7 Aug 2026
- **Also known as:** GHSA-j2vp-f2pv-5rj4

## What is CVE-2026-64663?

CVE-2026-64663 is a medium-severity code injection vulnerability in statamic cms, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Statamic is a Laravel and Git powered content management system (CMS). Prior to 5.74.1 and 6.24.0, manipulating user-supplied input incorporated into Antlers templates could result in the loss of content and assets, on sites whose templates pass untrusted input into affected areas, and exploitation did not require authentication. This issue is fixed in versions 5.74.1 and 6.24.0.

Weakness: CWE-470 (Use of Externally-Controlled Input to Select Classes or Code)

## Which versions are affected by CVE-2026-64663?

4 open source packages ship an affected version, including statamic/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `statamic/cms` | Packagist | All versions | 5.74.1 |
| `statamic/cms` | Packagist | All versions | 5.74.1 |
| `statamic/cms` | Packagist | From 6.0.0 | 6.24.0 |
| `statamic/cms` | Packagist | From 6.0.0 | 6.24.0 |

## How do I fix CVE-2026-64663?

Upgrade statamic/cms to a fixed version for your release line: 5.74.1 or 6.24.0.

## Is CVE-2026-64663 being exploited?

There is no known exploitation of CVE-2026-64663 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-64663 and fix it if it is affected.

What it is: CVE-2026-64663 is a medium-severity code injection vulnerability in statamic cms, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-64663 in the wild and no public exploit code.

Affected packages and fixed versions:
- statamic/cms (Packagist): affected all versions; fixed in 5.74.1
- statamic/cms (Packagist): affected all versions; fixed in 5.74.1
- statamic/cms (Packagist): affected from 6.0.0; fixed in 6.24.0
- statamic/cms (Packagist): affected from 6.0.0; fixed in 6.24.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-64663/ (Markdown: https://insights.sbomify.com/CVE-2026-64663/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-64663
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-64663
- OSV: https://osv.dev/vulnerability/CVE-2026-64663

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-64663/
Summaries are generated and may contain mistakes; the official description above is the record.
