# CVE-2026-64677: Anki's local HTTP server is vulnerable to directory traversal attacks

> Attackers can read local files via directory traversal in Anki's local HTTP server, exposing sensitive data to malicious scripts or websites.

- **Severity:** Medium 5.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 6 Aug 2026
- **Updated:** 8 Aug 2026
- **Also known as:** GHSA-78wr-2gg2-4hqg, UBUNTU-CVE-2026-64677

## What is CVE-2026-64677?

CVE-2026-64677 is a medium-severity path traversal vulnerability in ankitects anki, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Anki is a program for creating and reviewing flashcards. Prior to 25.09.3, endpoints in Anki's local HTTP server do not adequately constrain requested media and built-in data paths, allowing scripts served from shared decks, or malicious websites combined with an origin-check bypass, to read local files through directory traversal. This issue is fixed in version 25.09.3.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-64677?


## How do I fix CVE-2026-64677?

No fix has been published for CVE-2026-64677 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-64677 being exploited?

There is no known exploitation of CVE-2026-64677 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-64677 and fix it if it is affected.

What it is: CVE-2026-64677 is a medium-severity path traversal vulnerability in ankitects anki, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-64677 in the wild and no public exploit code.

Affected product: ankitects anki. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-64677/ (Markdown: https://insights.sbomify.com/CVE-2026-64677/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-64677
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-64677
- OSV: https://osv.dev/vulnerability/CVE-2026-64677

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-64677/
Summaries are generated and may contain mistakes; the official description above is the record.
