CVE-2026-64685 ImageMagick: Heap Buffer Over-Read in BGR decoder due to mising end-of-file check
A heap buffer over-read in the BGR decoder allows attackers to cause denial of service or disclose memory via crafted images.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-64685?
CVE-2026-64685 is a medium-severity memory corruption vulnerability in Imagemagick Imagemagick, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
ImageMagick is free and open-source software used for editing and manipulating digital images. In versions prior to 7.1.2-27, the BGR decoder does not check for an end-of-file in every location so a crafted image could result in an heap buffer over-read. This issue has been fixed in version 7.1.2-27.
Weakness: CWE-125
Which versions are affected by CVE-2026-64685?
It affects 1 product.
Linux distribution packages (4)
ImageMagick SUSE:Linux Enterprise Module for Desktop Applications 15 SP7 | All versions | 7.1.0.9-150400.6.110.1 |
ImageMagick SUSE:Linux Enterprise Module for Desktop Applications 15 SP7 | All versions | 7.1.1.43-150700.3.79.1 |
ImageMagick SUSE:Linux Enterprise Module for Development Tools 15 SP7 | All versions | 7.1.1.43-150700.3.79.1 |
ImageMagick openSUSE:Tumbleweed | All versions | 7.1.2.28-2.1 |
Products include Imagemagick Imagemagick.
How do I fix CVE-2026-64685?
Upgrade to a fixed version.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2026-64685 being exploited?
There is no known exploitation of CVE-2026-64685 in the wild and no public exploit code.
Other vulnerabilities in Imagemagick Imagemagick
Sources
Also known as CLSA-2026-1786499335, DEBIAN-CVE-2026-64685, ECHO-f142-d9d7-0563, GHSA-7rgw-xg25-prjm, JLSEC-2026-1082, MINI-c5vj-xw2v-q377 and 5 more.