CVE-2026-6470 PostgreSQL fails to check type USAGE privilege
An object creator can cause denial of service against ALTER and DROP operations by creating a dependency on a type due to missing privilege checks.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-6470?
CVE-2026-6470 is a medium-severity missing authorization vulnerability in Postgresql Postgresql, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Missing authorization in PostgreSQL DDL commands allows an object creator to achieve denial of service against ALTER and DROP of the type, via creating a dependency on the type. Many DDL operations did check the privilege, but assigning a range subtype and referencing the type from an SQL expression did not. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
Weakness: CWE-862
Which versions are affected by CVE-2026-6470?
1 open source package ship an affected version, including postgresql. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
postgresql Bitnami | All versions | 14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0 |
Products include Postgresql Postgresql.
How do I fix CVE-2026-6470?
Upgrade postgresql to a fixed version for your release line: 14.24.0, 15.19.0, 16.15.0 or 17.11.0.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-6470 being exploited?
There is no known exploitation of CVE-2026-6470 in the wild and no public exploit code.
Other vulnerabilities in Postgresql Postgresql
Sources
Also known as ALPINE-CVE-2026-6470, AZL-95738, BELL-CVE-2026-6470, BIT-postgresql-2026-6470, DEBIAN-CVE-2026-6470, ECHO-40e5-0764-92ff and 8 more.