CVE-2026-6471 PostgreSQL logical decoding can dlopen arbitrary file
A non-superuser with REPLICATION privilege can execute arbitrary code by loading a malicious logical decoding plugin, requiring an upgrade to patched PostgreSQL versions.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-6471?
CVE-2026-6471 is a high-severity missing authorization vulnerability in Postgresql Postgresql, published on 13 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Missing authorization in PostgreSQL logical decoding allows a non-superuser holding REPLICATION privilege to dlopen any file visible to the operating system account running the server, via the choice of logical decoding plugin. This in turn runs arbitrary code as that account. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
Weakness: CWE-862
Which versions are affected by CVE-2026-6471?
1 open source package ship an affected version, including postgresql. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
postgresql Bitnami | All versions | 14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0 |
Products include Postgresql Postgresql.
How do I fix CVE-2026-6471?
Upgrade postgresql to a fixed version for your release line: 14.24.0, 15.19.0, 16.15.0 or 17.11.0.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-6471 being exploited?
There is no known exploitation of CVE-2026-6471 in the wild and no public exploit code.
Public exploit code: 2 proofs of concept on GitHub.
Other vulnerabilities in Postgresql Postgresql
Sources
Also known as ALPINE-CVE-2026-6471, AZL-95696, BELL-CVE-2026-6471, BIT-postgresql-2026-6471, CLSA-2026-1789374673, DEBIAN-CVE-2026-6471 and 10 more.