{"answers":{"affected":"1 open source package ship an affected version, including postgresql. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-6471 in the wild and no public exploit code.","fix":"Upgrade postgresql to a fixed version for your release line: 14.24.0, 15.19.0, 16.15.0 or 17.11.0.","what":"CVE-2026-6471 is a high-severity missing authorization vulnerability in Postgresql Postgresql, published on 13 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-6471 and fix it if it is affected.\n\nWhat it is: CVE-2026-6471 is a high-severity missing authorization vulnerability in Postgresql Postgresql, published on 13 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-6471 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postgresql (Bitnami): affected all versions; fixed in 14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-6471/ (Markdown: https://insights.sbomify.com/CVE-2026-6471/index.md)","id":"CVE-2026-6471","markdown":"https://insights.sbomify.com/CVE-2026-6471/index.md","name":"CVE-2026-6471","record":{"aliases":["ALPINE-CVE-2026-6471","AZL-95696","BELL-CVE-2026-6471","BIT-postgresql-2026-6471","CLSA-2026-1789374673","DEBIAN-CVE-2026-6471","ECHO-16b4-af99-5729","GHSA-r26j-h78w-pjqm","MINI-3235-vfg3-4qmx","MINI-56j7-pq6j-gr46","MINI-773w-w2g2-5cv3","MINI-9qj2-f2xr-prgr","MINI-wh4c-v94c-3948","MINI-wppq-6c59-fg3g","ROOT-OS-DEBIAN-11-CVE-2026-6471","UBUNTU-CVE-2026-6471"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL database","requires_auth":"high_privilege","summary":"A non-superuser with REPLICATION privilege can execute arbitrary code by loading a malicious logical decoding plugin, requiring an upgrade to patched PostgreSQL versions.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PostgreSQL","cpe":[{"product":"postgresql","vendor":"postgresql"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"Missing authorization in PostgreSQL logical decoding allows a non-superuser holding REPLICATION privilege to dlopen any file visible to the operating system account running the server, via the choice of logical decoding plugin.  This in turn runs arbitrary code as that account.  Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2026-09-05","github_poc":2,"max_poc_stars":2,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-09-05T09:28:34Z","kind":"github_poc","ref":"https://github.com/0xredash/CVE-2026-6471","stars":2,"title":"CVE-2026-6471"},{"date":"2026-09-05T05:36:51Z","kind":"github_poc","ref":"https://github.com/goldendivider/cve-2026-6471-postgres-logical-decoding-dlopen","stars":0,"title":"postgres CVE-2026-6471 Exploit"}],"tier":"poc_unverified"},"has_fix":true,"headline":"PostgreSQL logical decoding can dlopen arbitrary file","id":"CVE-2026-6471","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"postgresql:postgresql","products":["postgresql:postgresql"],"type":"missing_authorization","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"PostgreSQL CREATE TYPE does not check multirange schema CREATE privilege","id":"CVE-2026-6472"},"packages":[{"ecosystem":"Bitnami","fixed":["14.24.0","15.19.0","16.15.0","17.11.0","18.5.0"],"introduced":["0","15.0.0","16.0.0","17.0.0","18.0.0"],"last_affected":[],"package":"postgresql","purl":"pkg:bitnami/postgresql","source":"BIT-postgresql-2026-6471"}],"prev":{"headline":"PostgreSQL fails to check type USAGE privilege","id":"CVE-2026-6470"},"products":["PostgreSQL"],"published":"2026-08-13","related":[{"cvss_score":10,"headline":"Information disclosure in n/a","id":"CVE-2013-1902","kev_date_added":null,"published":"2013-04-04"},{"cvss_score":10,"headline":"Information disclosure in n/a","id":"CVE-2013-1903","kev_date_added":null,"published":"2013-04-04"},{"cvss_score":10,"headline":"Privilege escalation in n/a","id":"CVE-2007-3279","kev_date_added":null,"published":"2007-06-19"},{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2002-1399","kev_date_added":null,"published":"2003-01-08"},{"cvss_score":9.1,"headline":"Information disclosure in n/a","id":"CVE-2016-3065","kev_date_added":null,"published":"2016-04-11"},{"cvss_score":9,"headline":"Code injection in n/a","id":"CVE-2007-3280","kev_date_added":null,"published":"2007-06-19"},{"cvss_score":8.8,"headline":"PostgreSQL tsvector and tsquery undersize allocations, via integer wraparound","id":"CVE-2026-14662","kev_date_added":null,"published":"2026-08-13"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-29","vendors":["n/a"]},"summary":"A non-superuser with REPLICATION privilege can execute arbitrary code by loading a malicious logical decoding plugin, requiring an upgrade to patched PostgreSQL versions.","url":"https://insights.sbomify.com/CVE-2026-6471/"}