# CVE-2026-6471: PostgreSQL logical decoding can dlopen arbitrary file

> A non-superuser with REPLICATION privilege can execute arbitrary code by loading a malicious logical decoding plugin, requiring an upgrade to patched PostgreSQL versions.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 29 Aug 2026
- **Also known as:** ALPINE-CVE-2026-6471, AZL-95696, BELL-CVE-2026-6471, BIT-postgresql-2026-6471, CLSA-2026-1789374673, DEBIAN-CVE-2026-6471, ECHO-16b4-af99-5729, GHSA-r26j-h78w-pjqm, MINI-3235-vfg3-4qmx, MINI-56j7-pq6j-gr46, MINI-773w-w2g2-5cv3, MINI-9qj2-f2xr-prgr, MINI-wh4c-v94c-3948, MINI-wppq-6c59-fg3g, ROOT-OS-DEBIAN-11-CVE-2026-6471, UBUNTU-CVE-2026-6471

## What is CVE-2026-6471?

CVE-2026-6471 is a high-severity missing authorization vulnerability in Postgresql Postgresql, published on 13 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Missing authorization in PostgreSQL logical decoding allows a non-superuser holding REPLICATION privilege to dlopen any file visible to the operating system account running the server, via the choice of logical decoding plugin.  This in turn runs arbitrary code as that account.  Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-6471?

1 open source package ship an affected version, including postgresql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | All versions | 14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0 |

Products: Postgresql Postgresql.

## How do I fix CVE-2026-6471?

Upgrade postgresql to a fixed version for your release line: 14.24.0, 15.19.0, 16.15.0 or 17.11.0.

## Is CVE-2026-6471 being exploited?

There is no known exploitation of CVE-2026-6471 in the wild and no public exploit code.

Public exploit code:

- CVE-2026-6471 (github_poc): https://github.com/0xredash/CVE-2026-6471
- postgres CVE-2026-6471 Exploit (github_poc): https://github.com/goldendivider/cve-2026-6471-postgres-logical-decoding-dlopen

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6471 and fix it if it is affected.

What it is: CVE-2026-6471 is a high-severity missing authorization vulnerability in Postgresql Postgresql, published on 13 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6471 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected all versions; fixed in 14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6471/ (Markdown: https://insights.sbomify.com/CVE-2026-6471/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6471
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6471
- OSV: https://osv.dev/vulnerability/CVE-2026-6471

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6471/
Summaries are generated and may contain mistakes; the official description above is the record.
