CVE-2026-6472 PostgreSQL CREATE TYPE does not check multirange schema CREATE privilege
Attackers can hijack queries via search_path to execute arbitrary SQL functions due to missing privilege checks in CREATE TYPE.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-6472?
CVE-2026-6472 is a medium-severity missing authorization vulnerability in Postgresql Postgresql, published on 14 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Missing authorization in PostgreSQL CREATE TYPE allows an object creator to hijack other queries that use search_path to find user-defined types, including extension-defined types. That is to say, the victim will execute arbitrary SQL functions of the attacker's choice. Versions before PostgreSQL 18.4, 17.10, 16.14, 15.18, and 14.23 are affected.
Weakness: CWE-862
Which versions are affected by CVE-2026-6472?
1 open source package ship an affected version, including postgresql. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
postgresql Bitnami | All versions | 14.23.0, 15.18.0, 16.14.0, 17.10.0, 18.4.0 |
Products include Postgresql Postgresql.
How do I fix CVE-2026-6472?
Upgrade postgresql to a fixed version for your release line: 14.23.0, 15.18.0, 16.14.0 or 17.10.0.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-6472 being exploited?
There is no known exploitation of CVE-2026-6472 in the wild and no public exploit code.
Other vulnerabilities in Postgresql Postgresql
Sources
Also known as ALPINE-CVE-2026-6472, AZL-86834, BELL-CVE-2026-6472, BIT-postgresql-2026-6472, DEBIAN-CVE-2026-6472, ECHO-07c3-3f85-b9ea and 9 more.