{"answers":{"affected":"1 open source package ship an affected version, including postgresql. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-6473 in the wild and no public exploit code.","fix":"Upgrade postgresql to a fixed version for your release line: 14.23.0, 15.18.0, 16.14.0 or 17.10.0.","what":"CVE-2026-6473 is a high-severity vulnerability in Postgresql Postgresql, published on 14 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-6473 and fix it if it is affected.\n\nWhat it is: CVE-2026-6473 is a high-severity vulnerability in Postgresql Postgresql, published on 14 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-6473 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postgresql (Bitnami): affected all versions; fixed in 14.23.0, 15.18.0, 16.14.0, 17.10.0, 18.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-6473/ (Markdown: https://insights.sbomify.com/CVE-2026-6473/index.md)","id":"CVE-2026-6473","markdown":"https://insights.sbomify.com/CVE-2026-6473/index.md","name":"CVE-2026-6473","record":{"aliases":["ALPINE-CVE-2026-6473","AZL-86822","BELL-CVE-2026-6473","BIT-postgresql-2026-6473","CLSA-2026-1779465604","CLSA-2026-1779465893","CLSA-2026-1779466432","CLSA-2026-1787395689","DEBIAN-CVE-2026-6473","ECHO-a6f1-a1c7-a609","GHSA-8rqw-w7xq-566r","JLSEC-2026-601","MINI-2gr8-8ghj-4p34","MINI-3jxf-rq5p-77hr","MINI-6p86-5773-f7w3","MINI-857j-pcmm-wprr","MINI-mm4x-68v7-xqqw","MINI-pgr7-rjrm-vjq3","UBUNTU-CVE-2026-6473"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL database server","requires_auth":"low_privilege","summary":"An unprivileged user can trigger an integer wraparound to cause out-of-bounds writes, potentially executing arbitrary code or crashing the server.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PostgreSQL","cpe":[{"product":"postgresql","vendor":"postgresql"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"Integer wraparound in multiple PostgreSQL server features allows an unprivileged database user to cause the server to undersize an allocation and write out-of-bounds.  This may execute arbitrary code as the operating system user running the database.  In applications that pass gigabyte-scale user inputs to the relevant database functions, the application input provider may achieve a segmentation fault.  Versions before PostgreSQL 18.4, 17.10, 16.14, 15.18, and 14.23 are affected.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PostgreSQL server undersizes allocations, via integer wraparound","id":"CVE-2026-6473","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"postgresql:postgresql","products":["postgresql:postgresql"],"type":"integer_overflow","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"PostgreSQL timeofday() can disclose portions of server memory","id":"CVE-2026-6474"},"packages":[{"ecosystem":"Bitnami","fixed":["14.23.0","15.18.0","16.14.0","17.10.0","18.4.0"],"introduced":["0","15.0.0","16.0.0","17.0.0","18.0.0"],"last_affected":[],"package":"postgresql","purl":"pkg:bitnami/postgresql","source":"BIT-postgresql-2026-6473"}],"prev":{"headline":"PostgreSQL CREATE TYPE does not check multirange schema CREATE privilege","id":"CVE-2026-6472"},"products":["PostgreSQL"],"published":"2026-05-14","related":[{"cvss_score":10,"headline":"Information disclosure in n/a","id":"CVE-2013-1902","kev_date_added":null,"published":"2013-04-04"},{"cvss_score":10,"headline":"Information disclosure in n/a","id":"CVE-2013-1903","kev_date_added":null,"published":"2013-04-04"},{"cvss_score":10,"headline":"Privilege escalation in n/a","id":"CVE-2007-3279","kev_date_added":null,"published":"2007-06-19"},{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2002-1399","kev_date_added":null,"published":"2003-01-08"},{"cvss_score":9.1,"headline":"Information disclosure in n/a","id":"CVE-2016-3065","kev_date_added":null,"published":"2016-04-11"},{"cvss_score":9,"headline":"Code injection in n/a","id":"CVE-2007-3280","kev_date_added":null,"published":"2007-06-19"},{"cvss_score":8.8,"headline":"PostgreSQL tsvector and tsquery undersize allocations, via integer wraparound","id":"CVE-2026-14662","kev_date_added":null,"published":"2026-08-13"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-25","vendors":["n/a"]},"summary":"An unprivileged user can trigger an integer wraparound to cause out-of-bounds writes, potentially executing arbitrary code or crashing the server.","url":"https://insights.sbomify.com/CVE-2026-6473/"}