# CVE-2026-6473: PostgreSQL server undersizes allocations, via integer wraparound

> An unprivileged user can trigger an integer wraparound to cause out-of-bounds writes, potentially executing arbitrary code or crashing the server.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 25 Aug 2026
- **Also known as:** ALPINE-CVE-2026-6473, AZL-86822, BELL-CVE-2026-6473, BIT-postgresql-2026-6473, CLSA-2026-1779465604, CLSA-2026-1779465893, CLSA-2026-1779466432, CLSA-2026-1787395689, DEBIAN-CVE-2026-6473, ECHO-a6f1-a1c7-a609, GHSA-8rqw-w7xq-566r, JLSEC-2026-601, MINI-2gr8-8ghj-4p34, MINI-3jxf-rq5p-77hr, MINI-6p86-5773-f7w3, MINI-857j-pcmm-wprr, MINI-mm4x-68v7-xqqw, MINI-pgr7-rjrm-vjq3, UBUNTU-CVE-2026-6473

## What is CVE-2026-6473?

CVE-2026-6473 is a high-severity vulnerability in Postgresql Postgresql, published on 14 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Integer wraparound in multiple PostgreSQL server features allows an unprivileged database user to cause the server to undersize an allocation and write out-of-bounds.  This may execute arbitrary code as the operating system user running the database.  In applications that pass gigabyte-scale user inputs to the relevant database functions, the application input provider may achieve a segmentation fault.  Versions before PostgreSQL 18.4, 17.10, 16.14, 15.18, and 14.23 are affected.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-6473?

1 open source package ship an affected version, including postgresql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | All versions | 14.23.0, 15.18.0, 16.14.0, 17.10.0, 18.4.0 |

Products: Postgresql Postgresql.

## How do I fix CVE-2026-6473?

Upgrade postgresql to a fixed version for your release line: 14.23.0, 15.18.0, 16.14.0 or 17.10.0.

## Is CVE-2026-6473 being exploited?

There is no known exploitation of CVE-2026-6473 in the wild and no public exploit code.

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6473 and fix it if it is affected.

What it is: CVE-2026-6473 is a high-severity vulnerability in Postgresql Postgresql, published on 14 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6473 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected all versions; fixed in 14.23.0, 15.18.0, 16.14.0, 17.10.0, 18.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6473/ (Markdown: https://insights.sbomify.com/CVE-2026-6473/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6473
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6473
- OSV: https://osv.dev/vulnerability/CVE-2026-6473

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6473/
Summaries are generated and may contain mistakes; the official description above is the record.
